SQL Server 服务安装概述

[image]

SQL Server 服务安装概述
请参阅 发送反馈

您可以利用 SQL Server 2012 服务更新将更新应用到任何已安装的 SQL Server 2012 组件。如果现有 SQL Server 2012 组件的版本级别高于更新版本的级别，则安装程序会将其从更新中排除。有关应用服务更新的详细信息，请参阅安装 SQL Server 2012 服务更新 (http://go.microsoft.com/fwlink/?LinkId=231297)。

安装 SQL Server 2012 更新时需要注意以下注意事项：

  • 必须同时更新属于一个 SQL Server 实例的所有功能。例如，更新数据库引擎时，如果 Analysis Services 组件和 Reporting Services 组件作为同一个 SQL Server 实例的一部分安装，则也必须对其进行更新。必须始终将诸如管理工具、SQL Server Data Tools (SSDT) 和 SQL Server Integration Services 等共享功能更新到最新状态。如果未在功能树中选定某个组件或实例，则不会更新该组件或实例。

  • 默认情况下，SQL Server 2012 更新日志文件将保存到 %Program Files%\Microsoft SQL Server\110\Setup Bootstrap\LOG\ 下。

  • SQL Server 安装程序现在可以将更新与原始介质集成，以便同时运行原始介质和更新。有关详细信息，请参阅 SQL Server 2012 安装中的产品更新和 SQL Server 安装中的新功能(http://go.microsoft.com/fwlink/?LinkID=219508)。

  • 建议您先备份您的数据，然后再应用 SQL Server 2012 服务更新。

  • SQL Server 更新可通过 Microsoft 获得。我们建议您定期扫描更新，以便将 SQL Server 实例保持为最新并确保其安全。SQL Server 2012 SP1 将作为完整 SQL Server 安装提供。对于此版本，没有在标准修补程序可执行文件包中提供 Service Pack 以应用到 SQL Server 2012 RTM 实例，而是提供安装包（包含 2 个文件）。执行时，将安装预安装 SP1 的 SQL Server 2012 新实例。有关详细信息，请参阅 SQL Server 2012 SP1 完全安装。

要求和已知问题

推荐的磁盘空间要求约为软件包的 2.5 倍，以便安装、下载和解压缩该软件包。安装完 Service Pack 后，可以删除下载的软件包。所有临时文件将会自动删除。

查看已知问题：有关当前版本的已知问题的详细信息，请参阅此处相应的发行说明主题：SQL Server 发行说明。

安装概述

本节讨论如何安装 SQL Server 2012 累计更新和 Service Pack，包括如何执行以下操作：

  • 准备安装 SQL Server 2012 更新

  • 安装 SQL Server 2012 更新

  • 重新启动服务和应用程序

准备安装 SQL Server 2012 更新

强烈建议在安装 SQL Server 2012 更新之前执行以下操作：

  • 备份 SQL Server 系统数据库 - 在安装 SQL Server 2012 更新前，备份 master、msdb 和 model 数据库。安装 SQL Server 2012 更新会更改这些数据库，使它们与 SQL Server 2012 的早期版本不兼容。如果决定重新安装 SQL Server 2012（不包含这些更新），则需要使用这些数据库的备份。

    出于谨慎起见，还应备份用户数据库。

    重要说明 重要提示

    将更新应用于参与复制拓扑的 SQL Server 实例时，必须在应用更新之前，将复制的数据库与系统数据库一起备份。

  • 备份 Analysis Services 数据库、配置文件和存储库 - 更新 Analysis Services 实例之前，应备份以下内容：

    • Analysis Services 数据库。默认情况下，这些组件安装在 C:\Program Files\Microsoft SQL Server\MSAS11.<实例 ID>\OLAP\Data\ 下。对于 WOW 安装，默认路径为 C:\ProgramFiles (x86)\Microsft SQL Server\MSAS11.<实例 ID>\OLAP\Data\。

    • msmdsrv.ini 配置文件中的 Analysis Services 配置设置。默认情况下，该文件位于 C:\Program Files\Microsoft SQL Server\MSAS11.<实例 ID>\OLAP\Config\ 目录下。

    • （可选）包含 Analysis Services 存储库的数据库。仅当已将 Analysis Services 配置为与决策支持对象 (DSO) 库一起使用后，才需要执行此步骤。

    注意 注意

    如果备份 Analysis Services 数据库、配置文件和存储库失败，则无法将更新后的 Analysis Services 实例恢复到早期版本。

  • 验证系统数据库是否有足够的可用空间 — 如果没有为 master 和 msdb 系统数据库选择自动增长选项，则每个数据库必须至少具有 500 KB 的可用空间。若要验证数据库是否有足够的空间，请对 master 和 msdb 数据库运行 sp_spaceused 系统存储过程。如果其中任一数据库的未分配空间少于 500 KB，则应增加该数据库的大小。

  • 停止服务和应用程序 — 为避免系统可能重启，请在安装 SQL Server 2012 更新前，停止与要升级的 SQL Server 实例连接的所有应用程序和服务。其中包括 SQL Server Management Studio 和 SQL Server Data Tools (SSDT)。有关详细信息，请参阅启动、停止、暂停、继续、重新启动数据库引擎、SQL Server 代理或 SQL Server Browser 服务。

    注意 注意

    不能停止故障转移群集环境中的服务。有关详细信息，请参阅本主题后面的故障转移群集安装一节。

  • 为了使更新安装后无需重新启动计算机，安装程序将显示锁定文件的进程列表。如果更新安装程序必须在安装过程中结束某个服务，它将在安装完成后重新启动该服务。

  • 如果安装程序确定在安装过程中文件已被锁定，则在安装完成后可能需要重新启动计算机。如有必要，安装程序将提示您重新启动计算机。

安装 SQL Server 2012 更新

本节介绍安装过程。

重要说明 重要提示

安装 SQL Server 2012 更新的帐户必须对要安装这些更新的计算机拥有管理权限。对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

启动 SQL Server 2012 更新

若要安装 SQL Server 2012 更新，请运行自解压缩包文件。

累积更新包 (CU)：<SQLServer2012>-KBxxxxxx-PPP.exe

Service Pack 包 (PCU)：<SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x 表示 Service Pack 编号

  • PPP 表示特定的平台。

  • LLL 表示 SQL Server 语言的字符缩写形式，例如：英语的 LLL 为 ENU。

若要将更新应用于故障转移群集中的 SQL Server 2012 组件，请参阅故障转移群集安装的相关章节。有关在无人参与模式下如何运行更新安装的详细信息，请参阅从命令提示符安装更新。

SQL Server 2012 安装中的产品更新

产品更新是 SQL Server 2012 安装程序中的一项新功能。该安装程序可以将最新的产品更新与主安装相集成，以便可以同时安装主产品及其适用的更新。产品更新可以搜索 Microsoft 更新、Windows Server Update Services (WSUS)、本地文件夹或网络共享区以便获得适用的更新。在安装程序找到最新版本的适用更新后，它将下载这些更新并且将其与当前 SQL Server 安装进程相集成。产品更新可请求累积更新、Service Pack 或者 Service Pack 连同累积更新。产品更新功能是已在 SQL Server 2008 PCU1 中提供的 Slipstream 功能的扩展。有关 SQL Server 2012 安装程序中的产品更新功能的详细信息，请参阅 SQL Server 2012 安装中的产品更新。

SQL Server 2012 SP1 完全安装

SQL Server 2012 SP1 也作为完整 SQL Server 安装包提供。SQL Server 2012 SP1 安装包将安装预安装 SP1 的新 SQL Server 实例。

该包包含一个可执行文件和一些压缩格式的安装文件。该包文件的格式为：SQLServer2012SP1-<体系结构>-<语言>.exe 和 SQLServer2012SP1-<体系结构>-<语言>.box。

安装 SQL Server 2012 SP1 时查看以下说明：

  • 从下载页将以下文件下载到您设备中的某个临时目录：

    • SQLServer2012SP1-architecture-language.box

    • SQLServer2012SP1-architecture-language.exe

  • 下载完成后，双击 SQLServer2012SP1-<体系结构>-<语言>.exe，以开始安装过程。

  • 在"选择解压缩文件的目录"对话框中， 预先填充了默认目录路径：<当前驱动器>\<当前工作文件夹>\<包名称>。例如 %temp%\SQLServer2012SP1-x64-ENU\。单击"浏览"以更改解压缩文件的目录路径。

  • 包解压缩到指定的安装路径，在安装完成后将留在所选目录路径中。用户将能在将来的安装中使用解压缩文件夹中的二进制文件。

  • 安装向导将运行 SQL Server 安装中心。按照使用安装向导安装 SQL Server 2012（安装程序）(http://msdn.microsoft.com/library/ms143219.aspx) 中的安装说明操作。

下表包含一些可用于解压缩 SQL Server 2012 SP1 包的一些命令行参数：

有关可直接提供给 SP1 包的支持的命令行参数详细列表，请参阅从命令提示符安装 SQL Server 2012 (http://msdn.microsoft.com/library/ms144259.aspx)

参数 | 说明
/x 或 -x | 将包解压缩到指定的路径。打开"选择解压缩文件的目录"对话框，然后将包解压缩到指定的路径。 它不运行安装程序。
/x:<路径> 或 -x:<路径> | 将包解压缩到指定的路径，不启动安装程序。
/q 或 -q | 指定在没有任何用户界面的情况下以静默模式运行安装程序。这适用于无人参与的安装。
/l:<路径> 或 -l:<路径> | 默认情况下，日志文件存储在 temp 目录中，名称为 SQLServer2012SPx-<体系结构>-<语言>_decompression_log.txt。 使用此参数将解压缩文件生成到指定的路径。 例如： SQLServer2012SP1-x64-ENU /x /l:<路径> 此选项应与 /x 或 -x 或者 /x:<路径> 或 -x:<路径> 一起使用。

更新 SQL Server 的已准备映像

可以在未完成已准备实例配置的情况下，将更新应用到未配置的 SQL Server 的已准备实例。下面介绍将更新应用到 SQL Server 的已准备实例的不同方法：

  • 更新前面所准备的 SQL Server 实例

    可在配置之前应用已准备实例的更新。该更新包检测实例是否处于已准备状态并将修补程序应用到已准备的实例，但不完成配置。

  • 通过 Microsoft Update 更新已准备实例：

    可以通过 Microsoft Update 将更新应用到 SQL Server 的已准备实例。该 Microsoft Update 包将检测实例是否处于已准备状态并将修补程序应用到已准备的实例，但不完成配置。

如果要更新 SQL Server 的已准备映像，则需要指定 InstanceID 参数。有关详细信息和语法示例，请参阅从命令提示符安装更新。

更新 SQL Server 的已完成映像

更新 SQL Server 的已完成和已配置实例的过程与更新任何其他 SQL Server 已安装实例的过程相同。

重新生成 SQL Server 2012 故障转移群集节点

应用更新之后，如果必须重新生成故障转移群集中的某个节点，请执行以下步骤：

  1. 在故障转移群集中重新生成该节点。有关重新生成节点的详细信息，请参阅从故障转移群集实例故障中恢复。

  2. 运行原始的 SQL Server 2012 安装程序，将 SQL Server 2012 安装在故障转移群集节点上。

  3. 在添加的节点上运行 SQL Server 2012 更新安装程序。

重新启动服务和应用程序

安装程序完成后，系统可能会提示您重新启动计算机。系统重新启动后，或者安装程序完成但未要求重新启动，请使用"控制面板"中的"服务"节点重新启动在应用 SQL Server 2012 更新之前停止的服务。其中包括像分布式事务处理协调器和 Microsoft Search 这样的服务，或实例特定的同等服务。

重新启动在运行 SQL Server 2012 更新安装程序之前关闭的应用程序。成功安装后，可能还需要立即对升级后的 master、msdb 和 model 数据库再进行一次备份。

从 SQL Server 2012 卸载更新

可以使用"控制面板"中的"程序和功能"卸载 SQL Server 2012 累积更新或 Service Pack。要查看已安装的更新列表，请通过依次单击"开始"按钮、"控制面板"、"程序"，然后在"程序和功能"下单击"查看已安装的更新"，打开"已安装的更新"。每个累积更新是分别列出的。但是，如果安装的 Service Pack 版本高于累积更新，累积更新条目将会隐藏起来，并且仅在卸载了 Service Pack 后才会显示出来。

若要卸载任何 Service Pack 和更新，必须按先新后旧顺序，先卸载应用于 SQL Server 实例的最新更新或 Service Pack。在下面的每个示例中，卸载完其他 Service Pack 或更新之后，最后剩下的都是 SQL Server 累积更新 1：

  • 对于安装有累积更新 1 和 SP1 的 SQL Server 2012 实例，先卸载 SP1。

  • 对于安装有累积更新 1、SP1 和累积更新 2 的 SQL Server 2012 实例，先卸载累积更新 2，然后卸载 SP1。

请参阅

其他资源

从命令提示符安装 SQL Server 2012
安装 SQL Server 2012 服务更新
验证 SQL Server 安装
查看和读取 SQL Server 安装程序日志文件
向 Microsoft 提供有关此主题的反馈

© 2012 Microsoft Corporation。保留所有权利。


文档法律声明

[image]

文档法律声明
发送反馈

本文档按"原样"提供。 本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。 您应承担使用本文档所带来的风险。

此处提及的某些示例只是为了便于说明，纯属虚构。 不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。 您可以出于内部参考目的复制和使用本文档。

© 2012 Microsoft。 保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。 SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。 所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

SQL Server 2012 软件文档包括 Microsoft 发布的 Microsoft SQL Server 2012 联机丛书、安装文档、开发人员参考文档、教程、自述文件、已知问题文档、示例代码、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容。 本支持和升级策略适用于 SQL Server 2012 文档，包括 SQL Server 2012 版本和 Service Pack 的自述文件；自述文件被视为 SQL Server 2012 联机丛书的扩展。

本文档中包含的示例主要用于说明概念以及特定语句或子句的合理用法。 大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。 对这些示例或所包括的源代码，我们不提供技术支持。

在某些情况下，SQL Server 2012 中的特定功能尚未经过充分测试或开发，不应予以使用。 此类功能通常都以占位符的形式出现。 因此，未对本软件所包含的某些功能提供文字说明。 未编档或标记用于 Microsoft 内部使用的功能均不应予以使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。 除非 SQL Server 2012 文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 SQL Server 2012 合并使用而导致的问题）提供支持，并且此类内容还可能导致数据丢失。 Microsoft 客户支持服务部门也不为利用或使用未说明的入口点（如未说明的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。

对于利用或使用未说明的入口点的应用程序和数据库，其服务器和数据库也可能无法升级至 SQL Server 2012 的未来版本，且此类服务器和数据库的升级不享受相关支持。 对于 Microsoft SQL Server 内包含但未在 SQL Server 2012 文档中提供文字说明的 SQL Server 特征和功能，不对其使用提供支持，且此类使用可能导致数据丢失。


从命令提示符安装更新

[image]

从命令提示符安装更新
请参阅 发送反馈

请根据您所在单位的需要测试并修改安装脚本。有关将更新安装到 SQL Server 故障转移群集的详细信息，请参阅 Microsoft 知识库中的 How to apply a SQL Server update to a failover cluster instance（如何将 SQL Server 更新应用到故障转移群集实例）。

安装的示例语法

更新包的名称可能会有变化，可能包含语言、版本和处理器组件。在命令提示符下应用更新，将 <包名称> 替换为更新包的名称：

  • 更新 SQL Server 的单一实例和所有共享组件（如 Integration Services 和管理工具）：可以使用 InstanceName 参数或 InstanceID 参数指定实例。要更新 SQL Server 的已准备实例，必须指定 InstanceID 参数<更新包名称>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance 或 <更新包名称>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<实例 ID>

  • 安装程序可以将最新的产品更新与主安装相集成，以便可以同时安装主产品及其适用的更新。您可以准备数据库引擎实例的安装以加入产品更新：setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<下载更新的路径> /INSTANCEID=<实例 ID> /FEATURES=SQLEngine

  • 仅更新 SQL Server 共享组件（如 Integration Services 和管理工具）：<更新包名称>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • 更新计算机上的所有 SQL Server 实例和所有共享组件（如 Integration Services 和管理工具）：<更新包名称>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

在命令提示符下删除更新，将 <更新包名称> 替换为更新包的名称：

  • 从单个 SQL Server 实例和所有共享组件（如 Integration Services 和管理工具）删除更新：<包名称>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • 仅从 SQL Server 共享组件（如 Integration Services 和管理工具）删除更新：<包名称>.exe /qs /Action=RemovePatch

    注意 注意

    更新安装程序可以确保共享组件始终采用不低于最高级别的实例版本。

支持的命令提示符参数

重要说明 重要提示

请尽可能在运行时提供安全凭据。如果必须将凭据存储在脚本文件中，请确保该文件的安全以防受到未经授权的访问。

开关 | 说明
/? | 显示无人参与安装命令提示符帮助
/action=Patch or /action=RemovePatch | 指定安装操作：Patch 或 RemovePatch。
/allinstances | 将 SQL Server 更新应用于所有 SQL Server 实例以及所有不识别实例的 SQL Server 共享组件。
/instancename=InstanceName1 | 将 SQL Server 更新应用于名为 InstanceName 的 SQL Server 实例以及所有不识别实例的 SQL Server 共享组件。
/InstanceID=Inst1 | 将 SQL Server 更新应用于 SQL Server Inst1 实例，以及所有 SQL Server 共享组件和不识别实例的组件。
/quiet | 在无人参与模式下运行 SQL Server 更新安装程序。
/qs | 仅显示进度 UI 对话。
/UpdateEnabled | 指定 SQL Server 安装程序是否应发现和加入产品更新。有效的值为 True 和 False 或 1 和 0。默认情况下，SQL Server 安装程序将加入找到的更新。
/UpdateSource | 指定 SQL Server 安装程序将获取产品更新的位置。有效值为"MU"，它表示搜索 Microsoft 更新，这是一个有效的文件夹路径，一个相对路径，例如 .\MyUpdates 或 UNC 共享。默认情况下，SQL Server 安装程序将通过 Windows Server Update Services 搜索 Microsoft 更新或 Windows 更新服务。
/IAcceptSQLServerLicenseTerms | 仅在为无人参与安装指定了 /Q 或 /QS 参数时是必需的。

1 不能通过指定此参数来将更新应用于 SQL Server 的已准备实例。必须指定 /instanceID 参数。

请参阅

概念

SQL Server 服务安装概述


如何验证 SQL Server 更新的安装是否成功

[image]

如何验证 SQL Server 更新的安装是否成功
请参阅 发送反馈

若要验证 SQL Server 更新的安装是否成功：

  • 验证 SQL Server 服务是否处于联机状态。

  • 验证由 @@version 查询返回的版本信息。

请参阅

概念

SQL Server 服务安装概述


获取 SQL Server 帮助

[image]

获取 SQL Server 帮助
请参阅 发送反馈

Microsoft 有以下三个关于 SQL Server 的主要信息来源：

  • 作为 SQL Server 联机丛书的本地集合安装的文档。

  • Microsoft Developer Network (MSDN) 和 TechNet 上的 SQL Server 站点。

  • 其他 Microsoft 网站上的 SQL Server 信息。

如果在这些来源中没有找到所需信息，可以在 SQL Server 社区论坛和新闻组中提问，也可以向 Microsoft 寻求帮助，以便解决具体问题。

SQL Server 联机丛书

SQL Server 联机丛书介绍了使用 SQL Server 所需的概念和过程。 联机丛书还包含有关使用 SQL Server 存储、检索、报告和修改数据的语言和编程接口的参考材料。

可通过下列方式访问联机丛书：

  • 在 Internet 上的 MSDN Library 和 TechNet Library 中发布 SQL Server 2012 联机丛书的副本。 SQL Server 联机丛书的这些副本中的主题包括社区评论，如其他客户的附加信息和代码示例。 您可以查看位于 SQL Server 2012 联机丛书上的 MSDN Library 副本。

  • 可以使用帮助库管理器在本地计算机上安装 SQL Server 联机丛书。 有关详细信息，请参阅添加或删除帮助集。

Microsoft 发布对 SQL Server 联机丛书的更新时，会同时刷新 MSDN Library 中的 SQL Server 联机丛书副本和通过帮助库管理器访问的联机丛书文件。

MSDN 和 TechNet 上的信息

Microsoft Developer Network (MSDN) 提供的联机服务和脱机服务有助于开发人员使用 Microsoft 产品和技术编写应用程序。 Microsoft TechNet 计划提供的全面技术资源有助于 IT 专业人员有效地评估、部署和支持 Microsoft 解决方案。

MSDN 和 TechNet 上的几个站点为特定用户提供了一些链接，他们可通过这些链接获得与其工作关系最密切的 SQL Server 信息，其中包括 MSDN 或 TechNet 上的 SQL Server 联机丛书副本中的信息。 这些站点还包含可对 SQL Server 联机丛书中的信息进行扩展的信息。

下表介绍了这些资源及其目标用户。

资源 | 读者
SQL Server 开发人员中心 | 生成 SQL Server 数据库、报告系统和商业智能解决方案以及启用其应用程序和网站以使用这些系统的开发人员。
数据访问和存储开发人员中心 | 要使自己的应用程序和网站可以使用通过 SQL Server 和 Access 等产品存储的数据的开发人员。
XML 开发人员中心 | 其站点和应用程序使用 XML 进行数据存储和操作的网站制作者和应用程序开发人员。
SQL Server TechNet 站点 | 使用 SQL Server 规划、部署、管理和支持系统的管理员和操作员。

其他联机信息

这些 SQL Server 网站还提供其他 Microsoft 信息。

资源 | 说明
Microsoft SQL Server | 提供有关将 SQL Server 作为数据存储和商业智能工具进行评估的售前信息。
Microsoft 知识库 | 提供由 Microsoft 支持人员编写的 SQL Server 文章的可搜索存储库。
Microsoft Learning | 说明 SQL Server 的 Microsoft 培训和认证。
Microsoft Press | 列出有关 SQL Server 的 Microsoft Press 书籍。

从其他人获得帮助

如果在产品文档或 Web 中没有找到所需信息，则可以在 SQL Server 社区论坛和新闻组中提问。 也可以向产品支持人员寻求帮助。

注意 注意

请勿在 MSDN Library 或 TechNet Library 中 SQL Server 联机丛书主题底部的"社区评论"部分提问。 系统不监视在这些地方提出的问题，因此您通常得不到答案。 请在社区论坛和新闻组中提问，其他可以回答您所提出问题的客户会监视在这些地方提出的问题。

下表提供了指向这些资源的链接并说明了这些资源。

资源 | 说明
SQL Server IT 专业人员社区 | 提供指向 SQL Server 社区所监视的新闻组和论坛的链接。 还列出了诸如博客和网站之类的社区信息资源。 尽管不能保证获得答案，但 SQL Server 社区对解决问题还是非常有帮助的。
SQL Server 开发人员中心社区 | 此站点专门提供对 SQL Server 开发人员有用的新闻组、论坛和其他社区资源。
Microsoft 帮助和支持 | 您可以使用此网站来获得 Microsoft 专业支持人员的帮助，以便解决具体问题。

Microsoft 产品具有支持生命周期，该生命周期定义了每个版本的支持期限。 Microsoft 支持部门维护了一个定义 Microsoft 支持生命周期的页面。 该页面包含的链接指向指定 Microsoft 产品支持服务可用性的其他页面。 有关详细信息，请参阅 Microsoft Support Lifecycle（Microsoft 支持生命周期）。

请参阅

概念

使用 SQL Server 的产品文档


欢迎使用

[image]

欢迎使用
发送反馈

安装规则用于扫描将要安装更新的计算机。


许可条款

[image]

许可条款
发送反馈

使用"许可条款"页可接受此版本的许可条款。

选项

若要继续安装，则必须接受 SQL Server 许可条款。

使用"打印"按钮可打印此版本的许可条款副本。 若要结束安装，请单击"取消"。


选择功能

[image]

选择功能
发送反馈

使用"功能选择"页可选择要更新的 SQL Server 组件和功能。

选项

在左窗格中单击某个功能名称可查看相应的语言、操作系统、版本和状态详细信息。

若要更新某个组件或功能，请选中该功能名称旁边的复选框。 若要从此次更新中排除某个组件或功能，请清除该功能名称旁边的复选框。

可以在不同时间更新单台计算机上的多个 SQL Server 实例，但必须同时更新一个 SQL Server 实例中的所有组件。 必须更新所有共享组件，如工作站组件、MSXML 分析器、SQLXML、向后兼容组件和 VSS 编写器等。

如果不能更新某个组件，将在"详细信息"窗格中提供说明。


检查正在使用的文件

[image]

检查正在使用的文件
发送反馈

若要避免在安装 SQL Server 更新后重新启动 Windows，请使用"检查正在使用的文件"页来识别锁定 SQL Server 更新安装程序所需文件的进程。

停止与正在更新的 SQL Server 实例连接的所有应用程序和服务。 包括停止 SQL Server Management Studio 和 SQL Server Data Tools (SSDT)。

如果安装程序确定在安装过程中文件已被锁定，那么，您在安装完成后可能必须重新启动计算机。 如有必要，安装程序会提示您重新启动计算机。 如果安装程序必须在安装过程中停止某个服务，则在安装完成后将重新启动这个服务。

为了使安装后无需重新启动计算机，安装程序将显示正在锁定文件的进程的列表。 停止或结束列表中的进程和应用程序。 然后，单击"刷新检查"重新运行相应检查。 单击"停职检查"结束正在运行的检查。 如果找不到锁定的文件，则该表为空。 关闭或停止所有锁定的进程以后，单击"下一步"继续。

安装程序将信息记录在日志文件中。 有关如何查看日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件和如何阅读 SQL Server 安装日志文件。

日志文件中包括下列信息：

  • 进程的名称

  • SQL Server 功能的名称

  • 进程类型

  • 运行进程的帐户

  • 进程 ID

  • 锁定的文件的名称

名称 | 说明
进程 | 显示以下进程的全名，该进程正在使用要更新的文件。
类型 | 显示进程的类型。
帐户 | 显示运行进程的帐户。
进程 ID | 显示进程 ID。


准备更新

[image]

准备更新
发送反馈

使用"摘要"页可确认将应用于 SQL Server 实例的更改。 若要继续安装，请单击"安装"。


更新进度

[image]

更新进度
发送反馈

使用"安装进度"页可以在安装程序将更新应用于 SQL Server 实例及其组件时对安装程序进行监视。

选项

该表提供了 SQL Server 产品名称、其实例名称及安装状态等信息。


完成

[image]

完成
发送反馈

"完成"页用于确认安装状态。