SQL Server 安装文档概述

[image]

SQL Server 安装文档概述
发送反馈

SQL Server 安装文档以安装介质和在线两种方式提供。

在安装过程中提供的文档

在安装 SQL Server 的过程中，单击安装向导页上的"帮助"按钮，或在键盘上按 F1 键，即可立即了解完成该操作所需的信息。

SQL Server 安装概述主题

无论您是使用 SQL Server 安装向导还是命令提示符来安装 SQL Server，都最好通过阅读以下部分来做好准备：

  • 计划 SQL Server 安装。

    说明如何准备 SQL Server 安装。

  • 安装 SQL Server 2012

    说明安装 SQL Server 的选项。

  • 安装 SQL Server 2012 BI 功能

    说明作为 Microsoft BI 平台组成部分安装的 SQL Server 功能的选项，这些功能包括：Analysis Services、Integration Services、Reporting Services，以及用于创建或使用分析数据的若干客户端应用程序。

  • 升级到 SQL Server 2012

    介绍用于升级到 SQL Server 的选项。

如果正在安装 SQL Server 故障转移群集，请查看以下内容：

  • SQL Server 故障转移群集入门。

  • 安装故障转移群集前的准备工作。

向 Microsoft 提供有关此主题的反馈

© 2012 Microsoft Corporation。保留所有权利。


关于 SQL Server 许可条款

[image]

关于 SQL Server 许可条款
请参阅 发送反馈

安装 SQL Server 时，会将 Microsoft 软件许可条款复制到本地计算机。 当在同一台计算机上安装具有相同版本类别和语言的多个 SQL Server 实例时，许可条款的单个副本将适用于该版本类别和语言的所有实例。 这些文件将写入到：%ProgramFiles%\Microsoft SQL Server\110\License Terms\ 或 %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\。

在同一台计算机上安装相同 SQL Server 版本和语言的多个实例时，许可条款的单个副本将应用于该版本和语言的所有实例。

许可条款文件名指示 SQL Server 的版本以及 SQL Server 语言版本。 例如：

  • License_DEV_ENU.txt 表示 SQL Server Developer，英语版本。

  • License_STD_ITA.txt 表示 SQL Server Standard，意大利语版本。

  • License_UA_JPN.txt 表示 SQL Server 升级顾问，日语版本。

  • License_SQLNCLI_ENU.txt 表示 SQL Server Native Client，英语版本。

  • License_SQLXML4_KOR.txt 表示 SQLXML，朝鲜语版本。

  • License_SQLBI.rtf 表示 SQL Server 商业智能版。

  • License_ENTCORE.rtf 表示 SQL Server Enterprise 版：基于内核的许可。

  • License_ENT.rtf 表示 SQL Server Enterprise 版服务器/CAL 许可。

以下文件名段用于标识 SQL Server 版本：

  • ENT - Enterprise 版：服务器/客户端访问许可证 (CAL) 许可

  • ENTCORE - Enterprise 版：基于内核的许可

  • BI - 商业智能

  • DEV - Developer

  • STD - Standard

  • WEB - Web

  • EXPR - Express

以下文件名段用于标识对应的 SQL Server 语言：

  • ENU - 英语

  • JPN - 日语

  • FRA - 法语

  • ITA - 意大利语

  • KOR - 朝鲜语

  • DEU - 德语

  • ESN - 西班牙语

  • CHS - 简体中文

  • CHT - 繁体中文

  • PTB - 葡萄牙语（巴西）

  • RUS - 俄语

SQL Server 许可选项

有关 SQL Server 定价和许可选项的信息，请参阅 Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955) 网站。

请参阅

概念

SQL Server 的许可注意事项
Microsoft SQL Server 隐私声明
文档法律声明


SQL Server 的许可注意事项

[image]

SQL Server 的许可注意事项
请参阅 发送反馈

有关 SQL Server 许可选项的详细信息，请参阅该 Microsoft SQL Server 网站。

请参阅

参考

关于 SQL Server 许可条款

概念

Microsoft SQL Server 隐私声明
文档法律声明


文档法律声明

[image]

文档法律声明
发送反馈

本文档按"原样"提供。 本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。 您应承担使用本文档所带来的风险。

此处提及的某些示例只是为了便于说明，纯属虚构。 不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。 您可以出于内部参考目的复制和使用本文档。

© 2012 Microsoft。 保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。 SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。 所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

Microsoft SQL Server 2012 软件文档包括 Microsoft 发布的 Microsoft Microsoft SQL Server 2012 联机丛书、安装文档、开发人员参考文档、教程、自述文件、已知问题文档、示例代码、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容。 本支持和升级策略适用于 Microsoft SQL Server 2012 文档，包括 Microsoft SQL Server 2012 版本和 Service Pack 的自述文件；自述文件被视为 Microsoft SQL Server 2012 联机丛书的扩展。

本文档中包含的示例主要用于说明概念以及特定语句或子句的合理用法。 大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。 对这些示例或所包括的源代码，我们不提供技术支持。

在某些情况下，Microsoft SQL Server 2012 中的特定功能尚未经过充分测试或开发，不应予以使用。 此类功能通常都以占位符的形式出现。 因此，未对本软件所包含的某些功能提供文字说明。 未编档或标记用于 Microsoft 内部使用的功能均不应予以使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。 除非 Microsoft SQL Server 2012 文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 Microsoft SQL Server 2012 合并使用而导致的问题）提供支持，并且此类内容还可能导致数据丢失。 Microsoft 客户支持服务部门也不为利用或使用未说明的入口点（如未说明的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。

对于利用或使用未说明的入口点的应用程序和数据库，其服务器和数据库也可能无法升级至 Microsoft SQL Server 2012 的未来版本，且此类服务器和数据库的升级不享受相关支持。 对于 Microsoft SQL Server 内包含但未在 Microsoft SQL Server 2012 文档中提供文字说明的 SQL Server 特征和功能，不对其使用提供支持，且此类使用可能导致数据丢失。


Microsoft SQL Server 隐私声明

[image]

Microsoft SQL Server 隐私声明
发送反馈

有关 Microsoft SQL Server 2012 中用户数据收集组件的信息，请参阅 SQL Server 隐私声明


SQL Server 的默认实例和命名实例的文件位置

[image]

SQL Server 的默认实例和命名实例的文件位置
请参阅 发送反馈

安装 SQL Server 将安装一个或多个单独的实例。 无论是默认实例还是命名实例都有自己的一组程序文件和数据文件，同时还有在计算机上的所有 SQL Server 实例之间共享的一组公共文件。

对于包含数据库引擎、Analysis Services 和 Reporting Services 的 SQL Server 实例，每个组件都有一套完整的数据文件和可执行文件，以及由所有组件共享的公共文件。

为了隔离每个组件的安装位置，将为给定 SQL Server 实例中的每个组件都生成一个唯一的实例 ID。

重要说明 重要提示

程序文件和数据文件不能安装在以下位置：可移动磁盘驱动器、使用压缩的文件系统、系统文件所在的目录以及故障转移群集实例上的共享驱动器。

请勿删除以下任何目录或其内容：Binn、Data、Ftdata、HTML 或 1033。 如有必要，可以删除其他目录；但是，如果不卸载并重新安装 SQL Server，则可能无法检索失去的功能或数据。 不要删除或修改 HTML 目录中的任何 .htm 文件。 它们对于 SQL Server 工具的正常运行是必需的。

所有 SQL Server 实例的共享文件

单个计算机上的所有实例使用的公共文件安装在文件夹 <drive>:\Program Files\Microsoft SQL Server\110\ 中，其中 <drive> 是安装组件的驱动器的盘符。 默认值通常为驱动器 C。

文件位置和注册表映射

SQL Server 安装过程中，为每个服务器组件生成一个实例 ID。 此 SQL Server 版本中的服务器组件分别是数据库引擎、Analysis Services 和 Reporting Services。

使用以下格式构造默认实例 ID：

  • 对于数据库引擎采用的是 MSSQL，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

  • 对于 Analysis Services 采用的是 MSAS，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

  • 对于 Reporting Services 采用的是 MSRS，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

此 Microsoft SQL Server 2012 版本中的默认实例 ID 的示例如下：

  • 对于默认 Microsoft SQL Server 2012 实例，为 MSSQL11.MSSQLSERVER。

  • 对于默认 Analysis Services 实例，为 MSAS11.MSSQLSERVER。

  • 对于名为"MyInstance"的 Microsoft SQL Server 2012 命名实例，为 MSSQL11.MyInstance。

包括数据库引擎和 Analysis Services 的 Microsoft SQL Server 2012 命名实例（名为"MyInstance"并且按照默认目录安装）的目录结构如下所示：

  • C:\Program Files\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL11.MyInstance\

可为实例 ID 指定任何值，但应避免使用特殊字符和保留关键字。 有关详细信息，请参阅Reserved Keywords (Setup)。

在 SQL Server 安装期间可指定一个非默认实例 ID。 如果用户选择更改默认安装目录，则不使用 <Program Files>\Microsoft SQL Server，而使用 <自定义路径>\Microsoft SQL Server。 请注意，不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

注意 注意

Integration Services 和客户端组件是不识别实例的，因此不为它们指定实例 ID。 默认状态下，将不识别实例的组件安装在单个目录中 <驱动器>:\Program Files\Microsoft SQL Server\110\ 中。 更改一个共享组件的安装路径会同时更改其他共享组件的安装路径。 后续安装会将非实例识别组件安装到与原始安装相同的目录。

SQL Server Analysis Services 是唯一的在安装后支持实例重命名的 SQL Server 组件。 如果重命名 Analysis Services 实例，实例 ID 不会发生变化。 重命名实例后，目录和注册表项将继续使用在安装期间创建的实例 ID。

将在 HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> 下为识别实例的组件创建注册表配置单元。 例如，

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

注册表还维护实例 ID 到实例名的映射。 实例 ID 到实例名的映射按如下方式维护：

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

指定文件路径

安装过程中，可以更改下列功能的安装路径：

安装程序中仅显示具有用户可配置目标文件夹的功能的安装路径：

组件 | 默认路径1, 2 | 可配置路径3或固定路径
数据库引擎服务器组件 | \Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\ | 可配置
数据库引擎数据文件 | \Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\ | 可配置
Analysis Services 服务器 | \Program Files\Microsoft SQL Server\MSAS11.<实例 ID>\ | 可配置
Analysis Services 数据文件 | \Program Files\Microsoft SQL Server\MSAS11.<实例 ID>\ | 可配置
Reporting Services 报表服务器 | \Program Files\Microsoft SQL Server\MSRS11.<实例 ID>\Reporting Services\ReportServer\Bin\ | 可配置
Reporting Services 报表管理器 | \Program Files\Microsoft SQL Server\MSRS11.<实例 ID>\Reporting Services\ReportManager\ | 固定路径
Integration Services | <安装目录>\110\DTS\ | 可配置4
Master Data Services | <安装目录>\110\Master Data Services | 可配置4
客户端组件 | <安装目录>\110\Tools\ | 可配置4
复制和服务器端 COM 对象 | <驱动器>:\Program Files\Microsoft SQL Server\110\COM\5 | 固定路径
用于数据转换运行时引擎、数据转换管道引擎和 dtexec 命令提示实用工具的 Integration Services 组件 DLL | <驱动器>:\Program Files\Microsoft SQL Server\110\DTS\Binn | 固定路径
为 Integration Services 提供托管连接支持的 DLL | <驱动器>:\Program Files\Microsoft SQL Server\110\DTS\Connections | 固定路径
Integration Services 支持的每种类型枚举器的 DLL | <驱动器>:\Program Files\Microsoft SQL Server\110\DTS\ForEachEnumerators | 固定路径
SQL Server 浏览器服务、WMI 提供程序 | <驱动器>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定路径
所有 SQL Server 实例共享的组件 | <驱动器>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定路径

1确保使用有限的权限对 \Program Files\Microsoft SQL Server\ 文件夹进行保护。

2这些位置的默认驱动器为 systemdrive，通常为驱动器 C。

3子功能的安装路径由父功能的安装路径决定。

4Integration Services 和客户端组件共享单个安装路径。 更改一个组件的安装路径会同时更改其他组件的安装路径。 后续安装将组件安装到与原始安装相同的位置。

5此目录由计算机上的所有 SQL Server 实例使用。 如果对计算机上的任一实例应用更新，则对此文件夹中的文件所做的任何更改都将影响计算机上的所有实例。 向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。 必须将其他功能安装到安装程序已建立的目录，或者卸载并重新安装产品。

注意 注意

对于群集配置，必须选择在该群集的每个节点上都可用的本地驱动器。

当在安装过程中为服务器组件或数据文件指定安装路径时，安装程序除了为程序和数据文件使用指定的位置外，还使用实例 ID。 安装程序不会将实例 ID 用于工具和其他共享文件。 安装程序也不会将任何实例 ID 用于 Analysis Services 程序和数据文件，尽管它会将实例 ID 用于 Analysis Services 存储库。

如果为数据库引擎功能设置了安装路径，则对于此次安装，SQL Server 安装程序会将该路径用作所有特定于实例的文件夹（包括 SQL 数据文件）的根目录。 在这种情况下，如果将根目录设置为"C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\"，则特定于实例的目录将添加到此路径的末尾。

在 SQL Server 安装向导（安装程序用户界面模式）中选择使用 USESYSDB 升级功能的客户会很容易将产品安装到递归文件夹结构中。 例如，<SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\。 这时，为了使用 USESYSDB 功能，请为 SQL 数据文件功能而非数据库引擎功能设置安装路径。

注意 注意

数据文件始终应位于名为 Data 的子目录中。 例如，当数据文件位于 C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data 下时，应指定 C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data 作为升级期间系统数据库的数据目录的根路径。

请参阅

参考

数据库引擎配置 - 数据目录
Analysis Services 配置 - 数据目录


查看和读取 SQL Server 安装程序日志文件

[image]

查看和读取 SQL Server 安装程序日志文件
请参阅 发送反馈

每次执行安装程序时，都会在一个带有时间戳的新日志文件夹 (%programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\) 中创建日志文件。 带有时间戳的日志文件夹的名称格式为 YYYYMMDD_hhmmss。 在无人参与模式下运行安装程序时，将在 % temp%\sqlsetup*.log 中创建日志。 日志文件夹中的所有文件将归档到各自日志文件夹的 Log*.cab 文件中。

一个典型的安装请求将经历以下三个执行阶段：

  1. 全局规则文本

  2. 组件更新

  3. 用户请求的操作

在每个阶段中，安装程序都生成详细信息日志和摘要日志，并根据需要创建其他日志。 在每次执行用户请求的安装操作时安装程序至少会被调用三次。

数据存储文件包含安装过程所跟踪的所有配置对象状态的快照，对于纠正配置错误来说非常有用。 XML 文件转储是为每个执行阶段的数据存储对象创建的。 它们保存在带有时间戳的日志文件夹下其自己的日志子文件夹中，如下所示：

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

以下部分介绍 SQL Server 安装程序日志文件。

摘要文本

概述

此文件显示在安装过程中检测到的 SQL Server 组件、操作系统环境、命令行参数值（如果已指定），以及执行的每个 MSI/MSP 的总体状态。

本日志归纳为以下部分：

  • 执行的总体摘要

  • 运行 SQL Server 安装程序的计算机的属性和配置

  • 计算机上先前安装的 SQL Server 产品功能

  • 安装版本和安装包属性的说明

  • 安装过程中提供的运行时输入设置

  • 配置文件的位置

  • 执行结果的详细信息

  • 全局规则

  • 特定于安装方案的规则

  • 失败的规则

  • 规则报表文件的位置

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\。

若要找到摘要文本文件中的错误，请使用"error"或"failed"关键字搜索该文件。

Summary_engine-base_YYYYMMDD_HHMMss.txt

概述

summary_engine 基本文件类似于摘要文件，是在主工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

概述

组件更新摘要日志文件类似于摘要文件，是在组件更新工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_<版本号>MMDD_HHMMss_GlobalRules.txt

概述

全局规则摘要日志文件类似于摘要文件，是在全局规则工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail.txt

概述

Detail.txt 是针对主工作流（如安装或升级）生成的，它提供有关执行的详细信息。 文件中的日志基于调用每个安装操作的时间而生成，并且显示操作的执行顺序以及其依赖项。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt。

如果在安装过程中发生错误，则将异常或错误记录在该文件的末尾。 若要查找该文件中的错误，请首先检查文件末尾，然后在文件中搜索"错误"或"异常"关键字。

Detail_ComponentUpdate.txt

概述

Detail_ComponentUpdate.txt 文件是针对组件更新工作流而生成的，它类似于 Detail.txt。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail_GlobalRules.txt

概述

Detail_GlobalRules.txt 是针对全局规则执行而生成的，它类似于 Detail.txt。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

MSI 日志文件

概述

MSI 日志文件提供安装包进程的详细信息。 它们是在安装指定的包的过程中由 MSIEXEC 生成的。

MSI 日志文件的类型：

  • <功能>_<体系结构>_<迭代>.log

  • <功能>_<体系结构>_<语言>_<迭代>.log

  • <功能>_<体系结构>_<迭代>_<工作流>.log

位置

MSI 日志文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<名称>.log。

该文件的末尾是有关执行的摘要，其中包括成功状态或失败状态以及属性。 若要找到 MSI 文件中的错误，请搜索"value 3"，通常可找到的错误与此字符串接近。

ConfigurationFile.ini

概述

本配置文件包含安装过程中提供的输入设置。 该文件可用于在无需手动输入设置的情况下重新启动安装。 但是，帐户的密码、PID 和某些参数不保存在该配置文件中。 可以将这些设置添加到该文件中，也可通过使用命令行或安装程序用户界面提供这些设置。 有关详细信息，请参阅使用配置文件安装 SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231296)。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

SystemConfigurationCheck_Report.htm

概述

系统配置检查报表包含有关每个执行规则的简短说明，以及执行状态。

位置

此文件位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

请参阅

概念

SQL Server 安装故障排除


SQL Server 安装故障排除

[image]

SQL Server 安装故障排除
请参阅 发送反馈

若要查看有关安装和升级问题的故障排除信息，请参阅 SQL Server 2012 自述文件 (http://go.microsoft.com/fwlink/?LinkId=196910)。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


SQL Server 安装程序的用户界面参考

[image]

SQL Server 安装程序的用户界面参考
发送反馈

本节说明 SQL Server 安装向导提供的安装选项。


接受许可条款

[image]

接受许可条款
请参阅 发送反馈

使用 SQL Server 安装向导的"接受许可条款"页可以接受该 SQL Server 版本的许可条款。

您可以打印许可协议或将其复制到剪贴板。 若要继续，请接受许可条款，然后单击"下一步"。 若要关闭安装过程，请单击"取消"。

功能使用情况报告

如果启用"功能使用情况"报告，SQL Server 将被配置为定期向 Microsoft 发送报告。 报告将包含有关硬件配置和用户如何使用 SQL Server 和组件的信息。 Microsoft 将使用功能使用情况数据来改进 SQL Server。 此功能监视的 SQL Server 组件包括以下各项：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • SQL Server 数据工具 (SSDT)

  • SQL Server 安装程序

有关功能使用情况的信息将发送到 Microsoft，在那里保存这些信息，且其访问将受到限制。

若要在安装程序完成后禁用功能使用情况报告，请使用 SQL Server"配置工具"菜单上的"SQL Server 错误和使用情况报告"工具。

对于诸如安装、升级、修复等此类安装程序操作，仅在执行安装程序期间才收集和上载信息。

对于所有其他 SQL Server 组件，将每天针对 SQL Server 的所有已启用实例收集一次信息。 收集时间默认为在午夜，以便最大程度上减小服务器的负载。 如果要更改收集时间，可以手动编辑控制收集时间的注册表项。 SQL Server 的各个实例有自己的注册表项：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

该注册表项的值包含运行收集的时间，以从 00:00（午夜）起的分钟数计。 例如，值为 60 会在凌晨 1:00 运行收集，而值为 1200 会在晚上 8:00 运行收集，等等。

请参阅

参考

关于 SQL Server 许可条款


添加 SQL Server 故障转移群集节点

[image]

添加 SQL Server 故障转移群集节点
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


Analysis Services 配置 - 帐户设置

[image]

Analysis Services 配置 - 帐户设置
请参阅 发送反馈

使用此页可以设置服务器节点，并向要求对 Analysis Services 进行不受限访问的用户或服务授予管理权限。 安装程序不会自动将本地 Windows 组 BUILTIN\Administrators 添加到要安装的实例的 Analysis Services 服务器管理员角色。 如果您想要将本地管理员组添加到服务器管理员角色，则必须显式指定该组。

如果您正在安装 PowerPivot for SharePoint，确保将管理权限授予负责在 SharePoint Server 2010 场中部署 PowerPivot 服务器的 SharePoint 场管理员或服务管理员。 有关 PowerPivot 服务安装和服务器帐户要求的详细信息，请参阅安装 PowerPivot for SharePoint。

选项

服务器节点 - 服务器节点指定可部署到服务器的 Analysis Services 数据库的类型。 服务器模式在安装过程中确定，之后不能修改。 各模式是互斥的，也就是说，您需要两个 Analysis Services 实例，它们配置为不同的模式，以便同时支持典型 OLAP 和表格模型解决方案。

指定管理员 — 您必须为 SQL Server 实例指定至少一个服务器管理员。 您指定的用户或组将成为所安装的 Analysis Services 实例的服务器管理员角色的成员。 这些都必须是与安装该软件的计算机处于同一域中的 Windows 域用户帐户。

注意 注意

用户帐户控制 (UAC) 是一个 Windows 安全功能，它要求在运行管理操作或应用程序之前，先由管理员专门审批。 由于 UAC 在默认情况下处于打开状态，因此系统将提示您允许需要提升权限的特定操作。 您可以配置 UAC 来更改默认行为，或针对特定程序自定义 UAC。 有关 UAC 和 UAC 配置的详细信息，请参阅 User Account Control Step by Step Guide（用户帐户控制分步指南）和 User Account Control (Wikipedia)（用户帐户控制 (Wikipedia)）。

请参阅

其他资源

更改服务帐户和密码 (PowerPivot for SharePoint)
配置 Analysis Services 服务帐户
设置 Windows 服务帐户


Analysis Services 配置 - 数据目录

[image]

Analysis Services 配置 - 数据目录
请参阅 发送反馈

下表中的默认目录是在 SQL Server 安装过程中可由用户配置的目录。 这些文件的访问权限授予了本地管理员和在安装过程中创建并配置的 SQLServerMSASUser$<实例> 安全组成员。

说明 | 默认目录 | 建议
数据根目录 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\ | 确保通过限制权限对 \Program files\Microsoft SQL Server\ 文件夹进行保护。 在许多配置中，Analysis Services 性能取决于数据目录所在的存储区的性能。 请将此目录放置在附加到系统上的最高性能存储区中。 对于故障转移群集安装，应确保数据目录位于共享磁盘上。
日志文件目录 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\ | 这是 Analysis Services 日志文件的目录，该目录包含 FlightRecorder 日志。 如果要延长网络流量记录器持续时间，请确保该日志目录有足够的空间。
Temp 目录 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\ | 将 Temp 目录放置在高性能存储子系统中。
备份目录 | C:\Program Files\Microsoft SQL Server\MSAS11.<实例 ID>\OLAP\Backup\ | 这是 Analysis Services 默认备份文件的目录。 对于 PowerPivot for SharePoint 安装，这还是 PowerPivot 系统服务缓存 PowerPivot 数据文件的位置。 确保设置合适的权限以防止数据丢失，并确保 Analysis Services 服务的用户组具有写入备份目录的足够权限。 不支持对备份目录使用映射的驱动器。

注释

  • 在 SharePoint 场上部署的 Analysis Services 实例将应用程序文件、数据文件和属性存储于内容数据库和服务应用程序数据库中。

  • 向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。 此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。 SQL Server 实例中的数据库引擎和 Analysis Services 组件也应安装到单独的目录。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的共享驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置


群集磁盘选择

[image]

群集磁盘选择
发送反馈

使用 SQL Server 安装向导的"群集磁盘选择"页为 SQL Server 故障转移群集选择共享群集磁盘资源。 群集磁盘用于存放 SQL Server 数据。

共享群集磁盘不是 SQL Server数据库引擎群集安装必需的。 SMB 文件服务器是一种受支持的 SQL Server数据库引擎故障转移群集安装的存储系统，在完成安装前可以通过"数据库引擎 - 数据目录"页指定。

注意事项 注意

如果选择了要安装 Analysis Services，您必须指定共享群集磁盘。

如果您计划在此 SQL Server 故障转移群集实例上启用 FILESTREAM，必须指定共享群集磁盘。

选项

共享磁盘

从列表中选择一个磁盘。 群集磁盘用于存放 SQL Server 数据。

只能指定一个磁盘。 如果选择包含群集仲裁资源的组，将显示警告。 建议不要安装到群集仲裁资源。

可用共享磁盘

显示可用磁盘的列表，对于列表中的每个磁盘，均会显示是否可用作共享磁盘以及磁盘资源的说明。


群集网络配置

[image]

群集网络配置
发送反馈

使用"群集网络选择"页可为故障转移群集实例指定网络资源。

选项

SQL Server 故障转移群集网络名称 - 此名称用于在网络上标识您的故障转移群集实例。

网络设置 - 指定故障转移群集实例的 IP 类型和 IP 地址。

在"添加节点"和"删除节点"操作期间，SQL Server 显示 SQL Server 故障转移群集的现有 IP 地址的只读列表。

  • 集成安装：

    • 如果您要添加一个节点，此节点支持由 SQL Server 故障转移群集的现有节点支持的同一组网络子网，则不能添加其他 IP 地址。 依赖关系设置保持不变。

    • 如果您要添加一个节点，此节点支持由 SQL Server 故障转移群集上的现有节点支持的子网的一个子集，则不能添加其他 IP 地址资源。将 IP 地址资源依赖关系设置为 OR，以反映指定的所有 IP 地址并非在所有群集节点上都有效。

    • 如果您要添加一个节点，此节点除了支持由 SQL Server 故障转移群集中的现有节点已经支持的子网之外，还支持其他子网，则您可以选择添加新的有效 IP 地址。 如果指定了新的 IP 地址，则 IP 地址资源依赖关系设置为 OR，以反映指定的所有 IP 地址并非在所有群集节点上都有效。

    • 如果您要添加一个节点，此节点支持其他网络子网，但不支持由 SQL Server 故障转移群集中的现有节点支持的子网，则您需要添加其他 IP 地址。 IP 地址资源依赖关系设置为 OR，以反映指定的所有 IP 地址并非在所有群集节点上都有效。

  • 高级安装：在安装过程的"完成"步骤中，为故障转移群集实例的所有节点和子网指定 IP 地址。 您可以为一个多子网故障转移群集指定多个 IP 地址，但每个子网只支持一个 IP 地址。 准备好的每个节点应至少是一个 IP 地址的所有者。 如果您在 SQL Server 故障转移群集中有多个子网，系统将提示您将 IP 地址资源依赖关系设置为 OR。删除节点：

    • 如果在所有剩余节点上都支持剩下的 IP 地址，系统会提示您将 IP 地址资源依赖关系设置为 AND。

    • 如果并非在所有剩余节点上都支持剩下的 IP 地址，则 IP 地址资源依赖关系保留为 OR。


群集节点配置

[image]

群集节点配置
发送反馈

使用"群集节点配置"页可以在故障转移群集实例中添加或删除节点。若要安装或升级 SQL Server 故障转移群集，必须在故障转移群集的每个节点上运行安装程序。 若要向现有的 SQL Server 故障转移群集添加节点，则必须在要添加至 SQL Server 故障转移群集实例的节点上运行 SQL Server 安装程序。

选项

SQL Server 实例名 - 使用该下拉列表可以选择要修改的 SQL Server 故障转移群集实例。

此节点的名称 - 将使用运行 SQL Server 安装程序的计算机名称填充此字段。 这就是将在 SQL Server 故障转移群集实例中添加或删除的故障转移群集节点。


群集节点配置(完成)

[image]

群集节点配置(完成)
发送反馈

使用"群集节点配置(完成)"页可以指定已准备好建立群集的现有 SQL Server 实例。若要安装或升级 SQL Server 故障转移群集，必须在故障转移群集的每个节点上运行安装程序。 若要向现有的 SQL Server 故障转移群集添加节点，则必须在要添加至 SQL Server 故障转移群集实例的节点上运行 SQL Server 安装程序。

选项

下拉框中有以下选项：

  • SQL Server 实例名 - 选择用于 SQL Server 故障转移群集的实例名称。

  • 此节点的名称 - 此字段使用运行 SQL Server 安装程序的计算机名称进行预先填充。

  • SQL Server 故障转移群集网络名称 - 此字段不进行预先填充。 为新的 SQL Server 故障转移群集实例指定网络名称， 该名称用来在网络上标识故障转移群集实例。


群集资源组

[image]

群集资源组
请参阅 发送反馈

使用"群集资源组"页可以指定用于放置 SQL Server 虚拟服务器资源的磁盘。

选项

指定 SQL Server 群集资源组名称。 您有以下两种选择：

  • 使用下拉框指定一个要使用的现有组。

  • 键入要创建的新组的名称。 请注意，名称"Available storage"不是有效的组名。

请参阅

其他资源

如何创建新的 SQL Server 故障转移群集


群集安全策略

[image]

群集安全策略
发送反馈

使用"群集安全策略"页可以为故障转移群集实例配置安全策略。

选项

为群集服务指定全局或本地域组。 所有资源权限都是由包括作为组成员的 SQL Server 服务帐户的域级组控制。 有关 Windows Server 2008 上的服务安全 ID (SID) 功能的详细信息，请参阅设置 Windows 服务帐户。

如果您在 Windows 2000 混合模式域中安装 Microsoft SQL Server 2012 故障转移群集实例，则必须对 SQL Server 群集服务使用全局域组。

注意 注意

Windows 2000 域控制器可以在混合模式和本机模式下运行。 混合模式允许同一域中存在下级域控制器。


完成 - 完成映像

[image]

完成 - 完成映像
发送反馈

使用"完成"页可以验证已准备实例的配置是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。 若要完成安装，请单击"关闭"。


完成映像进度

[image]

完成映像进度
请参阅 发送反馈

使用 SQL Server 安装向导的"完成映像进度"页可以监视 SQL Server 映像完成安装程序的状态。 在此步骤完成时，此页将列出已配置和已完成的每个 SQL Server 功能的状态。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


完成映像规则

[image]

完成映像规则
发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)


完成 - 准备映像

[image]

完成 - 准备映像
发送反馈

使用"完成"页可以验证映像准备是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。 若要完成映像准备，请单击"关闭"。


完成 - 修复

[image]

完成 - 修复
发送反馈

使用"完成 - 修复"页可以验证修复是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。 若要继续，请单击"关闭"。


完成 - 升级

[image]

完成 - 升级
发送反馈

使用"完成(升级)"页可以验证升级是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。 若要继续，请单击"关闭"。


数据库引擎配置 - 帐户设置

[image]

数据库引擎配置 - 帐户设置
请参阅 发送反馈

使用此页可以设置 SQL Server 安全模式，并添加 Windows 用户或组作为 SQL Server 数据库引擎的管理员。

在 Windows Vista、Windows 7 和 Windows Server 2008 上运行 SQL Server 2012 时的注意事项

在以前版本的 SQL Server 中，将 BUILTIN\Administrators 组设置为数据库引擎中的登录名，本地 Administrators 组的成员可以使用其管理员凭据登录。 使用提升的权限并不是最好的做法。 在 Microsoft SQL Server 2012 中，BUILTIN\Administrators 组不作为登录名设置。 因此，您应为每个管理用户创建一个 SQL Server 登录名，并在安装 Microsoft SQL Server 2012 新实例的过程中将该登录名添加到 sysadmin 固定服务器角色中。 对于用来运行 SQL Server 代理作业的 Windows 帐户，您也应该执行这些操作。 这些作业包括复制代理作业。

选项

安全模式 - 选择"Windows 身份验证"或"混合模式身份验证"用于安装。

Windows 主体设置 - 在 SQL Server 的早期版本中，Windows Builtin\Administrator 本地组放入了 SQL Server sysadmin 服务器角色中，有效授予了 Windows 管理员对 SQL Server 实例的访问权限。 在 Microsoft SQL Server 2012 中，sysadmin 服务器角色中未设置 Builtin\Administrator 组。 而是改为由您在安装过程中为新安装显式设置 SQL Server 管理员。

重要说明 重要提示

您在安装过程中必须为新安装显式设置 SQL Server 管理员。 直到您完成此步骤之后，安装程序才允许您继续操作。

指定 SQL Server 管理员 - 您必须为 SQL Server 实例至少指定一个 Windows 主体。 若要添加用以运行 SQL Server 安装程序的帐户，请单击"当前用户"按钮。 若要向系统管理员列表中添加帐户或从中删除帐户，请单击"添加"或"删除"，然后编辑将拥有 SQL Server 实例的管理员权限的用户、组或计算机的列表。

完成列表的编辑后，单击"确定"，然后在配置对话框中验证管理员列表。 完成此列表后，请单击"下一步"。

如果选择"混合模式身份验证"，则必须为内置 SQL Server 系统管理员 (SA) 帐户提供登录凭据。

安全说明 安全说明

不要使用空密码。请使用强密码。

Windows 身份验证模式

当用户通过 Windows 用户帐户连接时，SQL Server 使用操作系统中的 Windows 主体标记验证帐户名和密码。 此为默认身份验证模式，比混合模式更为安全。 Windows 身份验证利用 Kerberos 安全协议，通过强密码的复杂性验证提供密码策略强制，提供帐户锁定支持，并且支持密码过期。

安全说明 安全说明

请尽可能使用 Windows 身份验证。

重要说明 重要提示

不要使用空密码。请使用强密码。切勿设置空密码或弱 sa 密码。

混合模式(Windows 身份验证或 SQL Server 身份验证)

允许用户使用 Windows 身份验证或 SQL Server 身份验证进行连接。 通过 Windows 用户帐户进行连接的用户可以使用经过 Windows 验证的可信连接。

如果必须选择"混合模式身份验证"并且要求使用 SQL 登录名以适应早期应用程序，则必须为所有 SQL Server 帐户设置强密码。

注意 注意

提供 SQL Server 身份验证只是为了向后兼容。 请尽可能使用 Windows 身份验证。

输入密码

输入并确认系统管理员 (sa) 登录名。 密码是抵御入侵者的第一道防线，因此设置强密码对于系统安全是绝对必要的。 切勿设置空密码或弱 sa 密码。

注意 注意

SQL Server 密码可包含 1 到 128 个字符，包括字母、符号和数字的任意组合。 如果选择"混合模式身份验证"，则必须输入强 sa 密码才能进入安装向导的下一页。

强密码指南

强密码不易被人猜出，也不易用计算机程序攻击。 强密码不能使用禁止的条件或字词，这些条件或字词包括：

  • 空条件或 NULL 条件

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

强密码不能是与安装计算机相关联的下列字词：

  • 当前登录到计算机的用户的名称。

  • 计算机名称。

强密码的长度必须多于 8 个字符，并且强密码至少要满足下列四个条件中的三个：

  • 它必须包含大写字母。

  • 它必须包含小写字母。

  • 必须包含数字。

  • 必须包含非字母数字字符；例如 #、% 或 ^。

此页上输入的密码必须符合强密码策略要求。 如果存在任何使用 SQL Server 身份验证的自动化过程，请确保该密码符合强密码策略要求。

相关内容

有关选择 Windows 身份验证和 SQL Server 身份验证的详细信息，请参阅 SQL Server 联机丛书中的"选择身份验证模式"主题。

有关选择帐户以运行 SQL Server 数据库引擎的详细信息，请参阅 SQL Server 联机丛书中的"配置 Windows 服务帐户和权限"主题。

请参阅

参考

配置 Windows 服务帐户和权限


数据库引擎配置 - 数据目录

[image]

数据库引擎配置 - 数据目录
请参阅 发送反馈

使用此页面可以指定 SQL Server 数据库引擎 程序和数据文件的安装位置。 根据安装类型，支持的存储可能包括本地磁盘、共享存储或 SMB 文件服务器。

若要将 SMB 文件共享指定为目录，您必须手动键入支持的 UNC 路径。 不支持浏览到 SMB 文件共享。 下面是 SMB 文件共享支持的 UNC 路径格式："\\Servername\ShareName\..."

SQL Server 的独立实例

下表列出了 SQL Server 的独立实例支持的存储类型和默认目录，用户可以在 SQL Server 安装过程中配置这些内容。

说明 | 支持的存储类型 | 默认目录 | 建议
数据根目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\ | SQL Server 安装程序将为 SQL Server 目录配置 ACL 并在配置过程中中断继承。
用户数据库目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data | 用户数据目录的最佳实践取决于工作量和性能要求。
用户数据库日志目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data | 确保日志目录有足够的空间。
临时数据库目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data | Temp 目录的最佳实践取决于工作量和性能要求。
临时数据库日志目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data | 确保日志目录有足够的空间。
备份目录 | 本地磁盘、SMB 文件服务器、共享存储 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Backup | 设置合适的权限以防止数据丢失，并确保 SQL Server 服务的用户帐户具有写入备份目录的足够权限。 不支持对备份目录使用映射的驱动器。

1 尽管支持共享磁盘，但不建议对 SQL Server 的独立实例采用这种做法。

SQL Server 故障转移群集实例

下表列出了 SQL Server 的故障转移群集实例支持的存储类型和默认目录，用户可以在 SQL Server 安装过程中配置这些内容。

说明

支持的存储类型

默认目录

建议

数据根目录

共享存储、SMB 文件服务器

<驱动器:>\Program Files\Microsoft SQL Server\

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

SQL Server 安装程序将为 SQL Server 目录配置 ACL 并在配置过程中中断继承。

用户数据库目录

共享存储、SMB 文件服务器

<驱动器:>Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

用户数据目录的最佳实践取决于工作量和性能要求。

用户数据库日志目录

共享存储、SMB 文件服务器

<驱动器:>\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

确保日志目录有足够的空间。

临时数据库目录

本地磁盘、共享存储、SMB 文件服务器

<驱动器:>\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

请确保指定的目录对所有群集节点都有效。 在故障转移期间，如果 tempdb 目录对故障转移目标节点不可用，则 SQL Server 资源将无法联机。

临时数据库日志目录

本地磁盘、共享存储、SMB 文件服务器

<驱动器:>\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Data

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

请确保指定的目录对所有群集节点都有效。 在故障转移期间，如果 tempdb 目录对故障转移目标节点不可用，则 SQL Server 资源将无法联机。

备份目录

本地磁盘、共享存储、SMB 文件服务器

<驱动器:>\Program Files\Microsoft SQL Server\MSSQL11.<实例 ID>\MSSQL\Backup

提示 提示

如果在"群集磁盘选择"页上选择了共享磁盘，则默认设置为第一个共享磁盘。 如果在"群集磁盘选择"页上没有进行任何选择，此字段默认为空。

设置合适的权限以防止数据丢失，并确保 SQL Server 服务的用户帐户具有写入备份目录的足够权限。 不支持对备份目录使用映射的驱动器。

需要考虑的安全性因素

安装程序将为 SQL Server 目录配置 ACL 并在配置过程中中断继承。

以下建议适用于 SMB 文件服务器：

  • 使用 SMB 文件服务器时，SQL Server 服务帐户必须是域帐户。

  • 用于安装 SQL Server 的帐户应对用作数据目录的 SMB 文件共享文件夹具有 FULL CONTROL NTFS 权限。

  • 用于安装 SQL Server 的帐户应具有对 SMB 文件服务器的 SeSecurityPrivilege 特权。 若要授予此特权，请使用文件服务器上的"本地安全策略"控制台将 SQL Server 安装帐户添加到"管理审核和安全日志"策略中。 在"本地安全策略"控制台中"本地策略"下的"用户权限分配"部分可以找到此设置。

注释

  • 向现有安装中添加功能时，不能更改先前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。 此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。 SQL Server 实例中的数据库引擎和 Analysis Services 组件也应安装到单独的目录。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的映射网络驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置

其他资源

对文件服务器的共享和 NTFS 权限


数据库引擎配置 - 文件流

[image]

数据库引擎配置 - 文件流
请参阅 发送反馈

使用此页可针对此 Microsoft SQL Server 2012 安装启用 FILESTREAM。FILESTREAM 通过将 varbinary(max) 二进制大型对象 (BLOB) 数据作为文件存储在一个 NTFS 文件系统中，从而将 SQL Server 数据库引擎 与该文件系统集成在一起。 Transact-SQL 语句可插入、更新、查询、搜索和备份 FILESTREAM 数据。 通过 Win32 文件系统接口可以流式方式访问数据。

针对 Transact-SQL 访问启用 FILESTREAM

选中此项可针对 Transact-SQL 访问启用 FILESTREAM。 必须选中此控制选项，才能使用其他控制选项。

针对文件 I/O 流访问启用 FILESTREAM

选中此项可针对 FILESTREAM 启用 Win32 流访问。

Windows 共享名

使用此控制选项可输入将用来存储 FILESTREAM 数据的 Windows 共享的名称。

允许远程客户端针对 FILESTREAM 数据启用流访问

选中此控制选项可允许远程客户端访问此服务器上的此 FILESTREAM 数据。

请参阅

参考

sp_configure (Transact-SQL)

概念

启用和配置 FILESTREAM


数据库引擎配置 - 用户实例

[image]

数据库引擎配置 - 用户实例
发送反馈

使用"用户实例"页可以为不具有管理员权限的用户生成单独的数据库引擎实例，并可以将用户添加到管理员角色中。

选项

启用用户实例

默认值为"启用"。 若要禁用用户实例的功能，请清除此复选框。

用户实例也称为子实例或客户端实例，是由父实例（作为服务运行的主实例，如 SQLExpress）代表用户生成的 SQL Server 实例。 用户实例作为用户进程在该用户的安全上下文中运行。 用户实例独立于父实例和该计算机上运行的任何其他用户实例。 用户实例功能也称为"作为正常用户运行"(RANU)。

注意 注意

在安装过程中设置为 sysadmin 固定服务器角色的成员的登录名都设置为模板数据库中的管理员。 除非被删除，否则它们是用户实例的 sysadmin 固定服务器角色的成员。

将用户添加到 SQL Server 管理员角色中

默认情况下不启用此选项。 若要将当前安装用户添加到 SQL Server 管理员角色中，请选中此复选框。

作为 BUILTIN\Administrators 成员的 Windows Vista 用户在连接到 SQL Server Express 时，不会自动添加到 sysadmin 固定服务器角色中。 只有已显式添加到服务器级管理员角色中的 Windows Vista 用户才能管理 SQL Server Express。 Built-In\Users 组的任一成员都可连接到 SQL Server Express 实例，但他们仅拥有执行数据库任务的有限权限。 因此，对于从先前 Windows 版本中的 BUILTIN\Administrators 和 Built-In\Users 继承 SQL Server Express 特权的用户，应在运行于 Windows Vista 上的 SQL Server Express 实例中为其显式授予管理特权。

若要在此安装程序完成后对用户角色进行任何更改，请使用 SQL Server 2005 外围应用配置器工具 (SQLSAC.exe)。 若要更新 SQL Server 系统管理员角色中的用户列表，请单击"添加新管理员"链接。

确保"要设置的用户"字段中列出了应更新其权限的用户的"域名\用户名"。 从"可用权限"窗格的 SQL Server 实例列表中选择要更新的角色，然后单击向右箭头。 若要将用户添加到 SQL Server 实例的所有可用实例的所有可用角色中，请单击向右双箭头。

若要在完成选择后实现这些更改，请单击"确定"。 若要在不进行更改的情况下结束使用此工具，请单击"取消"。


磁盘空间要求

[image]

磁盘空间要求
请参阅 发送反馈

使用"磁盘成本摘要"页可以检查选择安装的 SQL Server 功能的磁盘空间要求。

选项

如果所需的磁盘空间太大，应考虑以下选项：

  • 将安装目录更改为具有更多磁盘空间的驱动器。

  • 更改要安装的 SQL Server 功能。

  • 通过移动其他文件或应用程序在指定驱动器上腾出更多可用空间。

请参阅

其他资源

安装 SQL Server 2008 R2 的硬件和软件要求


分布式重播控制器配置

[image]

分布式重播控制器配置
发送反馈

使用 SQL Server 安装向导的"分布式重播控制器配置"页可以指定您希望向其授予针对分布式重播控制器服务的管理权限的用户。

具有管理权限的用户将可以不受限制地访问分布式重播控制器服务。

选项

添加当前用户

单击此按钮可以添加要向其授予针对分布式重播控制器服务的访问权限的用户。

添加

单击此按钮可以添加针对分布式重播控制器服务的访问权限。

移除

单击此按钮可以从分布式重播控制器服务中删除访问权限。


分布式重播客户端配置

[image]

分布式重播客户端配置
发送反馈

使用 SQL Server 安装向导的"分布式重播客户端配置"页可以指定您希望向其授予针对分布式重播客户端服务的管理权限的用户。

具有管理权限的用户将可以不受限制地访问分布式重播客户端服务。

选项

控制器名称

这是一个可选参数，并且默认值为 <blank>。

输入客户端计算机将与分布式重播客户端服务进行通信的控制器的名称。 注意以下事项：

  • 名称必须为完全限定域名 (FQDN)。 例如，位于 Microsoft 的产品层次结构中名为 server1 的主机必须具有 server1.products.microsoft.com 的 FQDN。

  • 如果您已经设置了一个控制器，则在配置每个客户端时输入该控制器的名称。

  • 如果您尚未设置控制器，则可以将控制器名称保留为空。 但是，您必须在"客户端配置"文件中手动输入控制器名称。

工作目录

为分布式重播客户端服务指定工作目录。

默认的工作目录为 <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\。

默认目录

为分布式重播客户端服务指定结果目录。

默认的结果目录为 <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\ResultDir\。


版本升级规则

[image]

版本升级规则
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动版本升级之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


错误报告

[image]

错误报告
发送反馈

使用 SQL Server 安装向导的"错误和使用情况报告设置"页，可以启用 SQL Server 的功能错误和使用情况报告功能。

选项

对于 Microsoft SQL Server 2012 中的 SQL Server 及其组件，功能使用情况数据收集和错误报告功能在默认情况下已禁用。

错误报告

如果启用错误报告功能，SQL Server 将配置为在下列任意 SQL Server 组件中发生错误时，自动发送报告到 Microsoft：

  • 数据库引擎

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

有关错误的信息将通过安全 (https) 连接发送到 Microsoft，在那里保存这些信息，且对其访问将受到限制。 另外，也可以将这些信息发送到您自己的"公司错误报告"服务器。

错误报告包含下列信息：

  • 发生问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 用户数字产品 ID（并非用于标识您的许可证）。

  • 计算机或代理服务器的网络 IP 地址。

  • 来自出错进程的内存或文件的信息。

Microsoft 无意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。 但是，错误报告可能包含来自导致错误的进程的内存或文件中的个人信息。 虽然使用这些信息有可能确定您的身份，但 Microsoft 不会将这些信息用于此目的。

有关 SQL Server 隐私和数据收集策略的详细信息，请参阅 Microsoft SQL Server 隐私声明。

如果启用了错误报告功能并出现错误，则 Windows 事件日志中可能会包含来自 Microsoft 的一条响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用 SQL Server 及其组件的所有实例的错误或功能使用情况报告，请转到"错误和使用情况报告设置"对话框并清除"功能使用情况"的复选框。 如果为 SQL Server 的多个组件（SQL Server 数据库引擎、Analysis Services、Reporting Services 和共享组件）启用了"错误报告"，则可以对个别组件以及共享组件（在"其他"中列出）的每个实例禁用"错误报告"。


故障转移群集报告

[image]

故障转移群集报告
发送反馈

使用"故障转移群集报告"页可以查看安装系统针对此操作所扫描得到的报告结果。

选项

若要查看扫描的详细报告，请单击报告链接。


查看功能

[image]

查看功能
请参阅 发送反馈

"查看功能"页是已准备好并且将在完成映像步骤结束时配置并完成的功能的只读列表。 该功能列表在准备映像步骤中选择，并且在完成映像步骤中无法修改。 除了显示的功能外，已准备实例还包括 SQL Server Browser、SQL Server Writer 和 SQL Server Native Client。

在完成了 SQL Server 的已准备实例的配置后，可以添加在 SQL Server 的已准备实例中未包括的其他功能。

组件组

组件和功能

数据库引擎服务

SQL Server 数据库引擎中包括以下组件：

  • 数据库引擎是用于存储、处理和保护数据的核心服务。

    • 复制：（可选）复制是一组技术，用于将数据和数据库对象从一个数据库复制和分发到另一个数据库，然后在数据库之间进行同步以维护一致性。

    • 全文搜索：（可选）全文搜索提供了针对 SQL Server 表中基于纯字符的数据发出全文查询的功能。

    • Data Quality Services（可选）：Data Quality Services (DQS) 是一种数据清理解决方案，使您能够发现您的数据源中不一致和不正确的数据，并提供自动化方法和交互式方法来清理数据。

Reporting Services

Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。 Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。

请参阅

其他资源

如何使用 SysPrep 安装 SQL Server


安装规则

[image]

安装规则
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


功能规则

[image]

功能规则
发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)


功能选择

[image]

功能选择
请参阅 发送反馈

使用 SQL Server 安装向导的"功能选择"页上的复选框为您的 SQL Server 安装选择组件。

安装 SQL Server 功能

在"功能选择"页上，SQL Server 功能分为两个主要部分："实例功能"和"共享功能"。

"实例功能"表示为每个实例安装一次的组件，这样，您将具有它们的多个副本（每个实例一个）。 每个实例都可以是具有不同修补程序级别的单独版本。 在您安装某一修补程序时，无论该修补程序是 Service Pack、修补程序还是累积更新，它都仅更新给定计算机上一个实例的文件，并且还会更新共享功能（如果这些共享功能尚未更新）。

"共享功能"是指给定计算机上所有实例所共有的功能。 上述每个共享功能都设计为与可并行安装的支持的 SQL Server 版本向后兼容（Service Pack、累积更新和修补程序）。

注意 注意

SQL Server SysPrep：数据库引擎和 Reporting Services 是唯一支持 SQL Server SysPrep 的 Microsoft SQL Server 2012 功能。 您可以在该过程的准备映像步骤中选择这些功能和组件。 在完成 SQL Server 的已准备映像时，不能进行选择。 有关详细信息，请参阅如何使用 SysPrep 安装 SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190965)。

SQL Server 故障转移群集：数据库引擎和 Analysis Services 组件是仅有的两个支持故障转移群集的 Microsoft SQL Server 2012 功能。 可以在故障转移群集节点上安装其他组件，如 Reporting Services 或 Integration Services，但这些组件不能识别群集，因此当该故障转移群集节点脱机时，这些组件的服务不进行故障转移。 有关详细信息，请参阅 SQL Server 故障转移群集入门 (http://go.microsoft.com/fwlink/?LinkId=190953)。

实例功能

选择各个组件组时，"说明"窗格中会显示相应的说明。 您可以选中任意一些复选框。 若要继续，必须进行选择。

功能

说明

数据库引擎服务

SQL Server 数据库引擎包括数据库引擎（用于存储、处理和保护数据的核心服务）、复制、全文搜索、用于管理关系数据和 XML 数据的工具以及 Data Quality Services (DQS) 服务器。

  • 数据库引擎是用于存储、处理和保护数据的核心服务。

  • 复制：可选：复制是一组技术，用于将数据和数据库对象从一个数据库复制和分发到另一个数据库，然后在数据库之间进行同步以维护一致性。

  • 全文搜索：可选：全文搜索提供了针对 SQL Server 表中基于纯字符的数据发出全文查询的功能。

  • Data Quality Services：可选：Data Quality Services (DQS) 是一个数据清除解决方案，它使您能够发现数据源中不一致和错误的数据，并提供计算机辅助的交互方法清除您的数据。 选中此复选框将安装 DQS 服务器。 完成 SQL Server 安装之后，您必须运行 DQSInstaller.exe 文件，才能完成 DQS 服务器安装。 如果安装的是 SQL Server 的默认实例，则此文件位于 C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn 中。

SQL Server 故障转移群集：选择"数据库引擎服务"时，复制和全文搜索组件是必需的，并由 SQL Server 故障转移群集安装的安装程序自动选择。

Analysis Services

Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。

Reporting Services - 本机

Reporting Services 本机模式包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。 Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。

重要说明 重要提示

  1. 安装程序不为 Reporting Services 扩展部署中的多个节点配置负载平衡和单 URL 寻址。 若要完成扩展部署，必须使用 Windows Server、Microsoft Application Center 或第三方群集管理软件。 有关设置 Web 场部署的详细信息，请参阅为扩展部署配置 Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199448)。

  2. Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 7.0 SP 1。

  3. Reporting Services 不支持同时在 64 位平台上和 64 位服务器的 32 位子系统 (WOW64) 上进行并行配置。

共享功能

由一台计算机上的所有 SQL Server 实例共享的功能安装在一个目录中。 其中包括：

功能

说明

Reporting Services -SharePoint

Reporting Services SharePoint 模式是一种基于服务器的应用程序，用于创建、管理报表并将报表传递到电子邮件、多种文件格式和基于 Web 的交互格式。 SharePoint 模式将报表查看和报表管理体验与 SharePoint 产品集成在一起。

用于 SharePoint 产品的 Reporting Services 外接程序

用于 SharePoint 产品的 Reporting Services 外接程序包含管理和用户界面组件，以便将 SharePoint 产品与 SharePoint 模式下的 Reporting Services 报表服务器集成在一起。

数据质量客户端

Data Quality Client 是一个独立的应用程序，它连接到 DQS 服务器，并提供一个直观的图形用户界面来执行数据清除和数据匹配操作，以及在 DQS 中执行管理任务。

SQL Server 数据工具1

SQL Server 数据工具 (SSDT) 提供 IDE 以便为以下商业智能组件生成解决方案：Analysis Services、Reporting Services 和 Integration Services。

（以前称作 Business Intelligence Development Studio）。

SSDT 还包含"数据库项目"，为数据库开发人员提供集成环境，以便在 Visual Studio 内为任何 SQL Server 平台（无论是内部还是外部）执行其所有数据库设计工作。 数据库开发人员可以使用 Visual Studio 中功能增强的服务器资源管理器，轻松创建或编辑数据库对象和数据或执行查询。

客户端工具连接

客户端工具包括用于在客户端和服务器之间进行通信的组件，其中包括用于 DB-Library、OLEDB for OLAP、ODBC、ADODB 和 ADOMD+ 的各种网络库。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

客户端工具向后兼容性

客户端工具向后兼容性包括以下组件：

  • SQL 分布式管理对象 (SQL-DMO)。 有关详细信息，请参阅 SQL Server 2012 中不再推荐使用的 SQL Server 功能 (http://go.microsoft.com/fwlink/?LinkId=190968)。

  • 决策支持对象 (DSO)。 有关详细信息，请参阅 SQL Server 2012 中 Analysis Services 功能的重大更改 (http://go.microsoft.com/fwlink/?LinkId=190970)。

客户端工具 SDK

包括包含针对程序员的资源的软件开发包。

文档组件

文档组件包括用于查看和管理帮助内容的组件。

管理工具 - 基本

管理工具 - 基本：它包含以下项：

  • SQL Server Management Studio 对于 SQL Server 数据库引擎、SQL Server Express、sqlcmd 实用工具和 SQL Server PowerShell 提供程序的支持

管理工具 - 完整：除基本版本中的组件以外，完整版还包括以下组件：

  • SQL Server Management Studio 对于 Reporting Services、Analysis Services 和 Integration Services 的支持

  • SQL Server Profiler

  • 数据库引擎优化顾问

  • SQL Server 实用工具管理

分布式重播控制器

分布式重播控制器协调分布式的重播客户端的操作。 在每个分布式重播环境中只能有一个控制器实例。 有关详细信息，请参阅 SQL Server 分布式重播 (http://go.microsoft.com/fwlink/?LinkId=229847)。

分布式重播客户端

多个分布式重播客户端一起来模拟 SQL Server 实例的工作负荷。 在每个分布式重播环境中可以有一个或多个客户端。 有关详细信息，请参阅 SQL Server 分布式重播 (http://go.microsoft.com/fwlink/?LinkId=229847)。

SQL 客户端连接 SDK

为数据库应用程序开发包括 SQL Server Native Client (ODBC/OLE DB) SDK。

Master Data Services

Master Data Services 是一个平台，用于将整个组织内不同系统中的数据集成到单一主数据源，以确保准确性和进行审核。 Master Data Services 选项安装 Master Data Services 配置管理器、程序集、Windows PowerShell 管理单元以及 Web 应用程序和服务的文件夹和文件。

LocalDB

LocalDB 是面向程序开发人员的 SQL Server Express 的执行模式。 在由特殊的连接字符串启动后，将自动创建和启动必需的 SQL Server 基础结构，使应用程序无需执行配置和管理任务即可使用数据库。

1安装 SQL Server 数据工具 (SSDT) 需要 Internet Explorer 6.0 SP1。

默认情况下，共享组件安装到 %Program Files%Microsoft SQL Server\ 中。 若要更改安装路径，请单击"浏览"按钮。 如果更改一个共享组件的安装路径，则要同时更改其他共享组件的安装路径。 后续安装会将共享组件安装到与原始安装相同的位置。

在基于 x64 的操作系统上，您可以指定 64 位组件的安装位置，以及 32 位组件在 WOW64 子系统上的安装位置。

安装 AdventureWorks 示例数据库

默认情况下，不会将示例数据库和示例代码作为 SQL Server 安装程序的一部分进行安装。 有关安装示例数据库和示例代码的详细信息，请参阅 Microsoft SQL Server 社区项目和示例 (http://go.microsoft.com/fwlink/?LinkId=87843)。

安装 Microsoft SQL Server 2012 后还可以获得有关示例的其他信息。 在"开始"菜单中，依次单击"所有程序"、Microsoft SQL Server 2012、"文档和教程"，再单击"Microsoft SQL Server 示例概述"。

请参阅

其他资源

SQL Server 2012 的版本和组件


功能选择（卸载）

[image]

功能选择（卸载）
发送反馈

使用"功能选择"-"卸载"页可以选择要从指定的 SQL Server 实例中删除的功能。

选项

可以选择功能的任意组合。


要升级的功能

[image]

要升级的功能
请参阅 发送反馈

使用 Microsoft SQL Server 2012 安装向导的"要升级的功能"页可以查看要升级至 Microsoft SQL Server 2012 的功能。

选项

  • 在此版本中无法对要升级的功能进行更改。 若要将功能添加到此 SQL Server 实例，请完成升级过程，重新启动安装程序，然后在安装中心上单击"全新安装或向现有安装添加功能"。

请参阅

其他资源

版本升级
使用升级顾问来准备升级
使用 SQL Server 的多个版本


全文搜索升级选项

[image]

全文搜索升级选项
发送反馈

使用 SQL Server 安装向导的"全文搜索升级选项"页选择用于此时要升级的数据库的全文搜索升级选项。

在 SQL Server 2005 和早期版本中，每个全文索引都驻留在属于文件组的全文目录中，它们均具有物理路径，并被视为数据库文件。 从 SQL Server 2008 开始，全文目录是表示一组全文索引的逻辑概念，即虚拟对象。 因此，新的全文目录不会视为带有物理路径的数据库文件。 但是，在升级包含数据文件的所有全文目录期间，将在相同磁盘上创建新的文件组。 这可以在升级后维护旧磁盘的 I/O 行为。 该目录的所有全文索引均被放置到新的文件组中（如果存在根路径）。 如果旧的全文目录路径无效，该升级则将全文索引保留在与基表相同的文件组中，或者保留在主文件组中（对于分区表）。

选项

当您从 SQL Server 2005 或 SQL Server 2008 升级到 Microsoft SQL Server 2012 时，请选择下列全文升级选项之一。

导入

导入全文目录。 一般情况下，导入速度比重新生成速度要快很多。 例如，当仅使用一个 CPU 时，导入的运行速度比重新生成要快 10 倍左右。 不过，从 SQL Server 2005 导入的全文目录不能使用在 SQL Server 2008 中引入的新的和增强的断字符，因此最终可能还是要重新生成全文目录。

注意 注意

重新生成可以以多线程模式运行，如果可用的 CPU 在 10 个以上，且您允许重新生成操作使用所有这些 CPU，则重新生成操作的运行速度可能比导入更快。

如果全文目录不可用，则会重新生成关联的全文索引。 此选项仅对 SQL Server 2005 数据库可用。

有关导入全文索引的影响的信息，请参阅本主题后面的"有关选择全文升级选项的注意事项"。

重新生成

使用在 SQL Server 2008 中引入的新的和增强的断字符重新生成全文目录。 重新生成索引可能需要一些时间，且升级后可能需要占用大量的 CPU 和内存。

重置

重置全文目录。 从 SQL Server 2005 升级时，将删除全文目录文件，但会保留全文目录和全文索引的元数据。 在进行升级后，所有全文索引将禁用更改跟踪，并且不会自动启动爬网。 在升级完成后，目录将保留为空，直至手动执行完全填充。

所有这些升级选项确保升级后的数据库从 SQL Server 2008 和更高版本的全文性能增强功能中完全受益。

重要说明 重要提示

有关在导入 SQL Server 2005 全文索引后使用新的断字符和将干扰词文件升级到非索引字表的信息，请参阅 Microsoft SQL Server 2012 的安装帮助中的主题"全文搜索升级"。

有关选择全文升级选项的注意事项

为升级选择升级选项时，请考虑以下几点：

  • 如何使用断字符？

    Microsoft SQL Server 2012 中的全文搜索服务包括在 SQL Server 2008 中引入的断字符和词干分析器。 这可能更改 SQL Server 2005 中特定文本模式或方案的全文查询结果。 因此，在选择适当的升级选项时，如何使用断字符非常重要：

    • 如果使用的全文语言的断字符在 SQL Server 2008 或更高版本中未发生更改，或者撤回准确性对您来说并不重要，则适合导入。 随后，如果遇到任何撤回问题，您只需通过重新生成全文目录即可升级到新的断字符。 有关详细信息，请参阅 Microsoft SQL Server 2012 的安装帮助中的主题"全文搜索升级"。

    • 如果您关心撤回准确性，并使用 SQL Server 2008 中经过改进的断字符之一，则适合重新生成。

  • 是否基于整数全文键列生成了任何全文索引？

    重新生成执行内部优化，在某些情况下该优化可提高升级的全文索引的查询性能。 具体来说，如果您具有的全文目录包含基表的全文键列为整数数据类型的全文索引，则重新生成将在升级后实现全文查询的理想性能。 在这种情况下，我们强烈建议使用"重新生成"选项。

    注意 注意

    对于 Microsoft SQL Server 2012 中的全文索引，建议采用整数数据类型作为全文键列。 有关详细信息，请参阅 Microsoft SQL Server 2012 联机丛书中的"Performance Tuning and Optimization (Full-Text Search)"（性能优化（全文搜索））。

  • 使服务器实例处于联机状态的优先级是什么？

    升级期间的导入或重新生成操作会占用很多 CPU 资源，这会延迟其余服务器实例的升级和联机。 如果使服务器实例尽快处于联机状态非常重要，并且希望在升级后运行手动填充，则适合"重置"。


完成 - 安装

[image]

完成 - 安装
请参阅 发送反馈

单击"关闭"完成安装。

请参阅

概念

验证 SQL Server 安装


安装必备组件

[image]

安装必备组件
发送反馈

为了成功安装 SQL Server，安装计算机上需要具有下列软件组件。 将由 SQL Server 安装程序安装这些软件组件：

  • .NET Framework 版本 4.0，适用于所有版本的Microsoft SQL Server 2012

  • SQL Server 安装程序支持文件

  • SQL Server Native Client

注意 注意

如果安装失败或被取消，将不会删除这些组件。 若要删除它们，请使用"控制面板"中的"添加或删除程序"。

选项

若要安装必备组件文件，请单击"安装"。 若要退出安装过程，请单击"取消"。


安装进度

[image]

安装进度
请参阅 发送反馈

使用 SQL Server 安装向导的"安装进度"页可以监视 SQL Server 安装程序的状态。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


安装类型

[image]

安装类型
发送反馈

使用 SQL Server 安装向导的"安装类型"页可以指定是安装 SQL Server 的新实例还是向现有实例中添加功能。

选项

选择指示您所做选择的单选按钮：

  • 执行 SQL Server 的全新安装

  • 向 SQL Server 的现有实例中添加功能

    如果选择与向现有实例中添加功能相对应的选项，则使用下拉列表选择要更新的 SQL Server 实例。

您只能向 SQL Server 的已准备映像添加 SysPrep 支持的功能（数据库引擎和 Reporting Services）。 只有在已准备实例完成后，才能添加 SysPrep 不支持的其他功能。

注意 安装故障转移群集实例之后，不能再向其中添加功能。 若要向现有故障转移群集中添加 SQL Server 功能，则必须执行全新安装才能安装单独的 SQL Server 实例。


实例配置

[image]

实例配置
发送反馈

使用 SQL Server 安装向导的"实例配置"页面可指定是创建 SQL Server 的默认实例还是其命名实例。 如果尚未安装 SQL Server 实例，则除非您指定命名实例，否则将创建默认实例。

每个 SQL Server 实例都由一组具有排列规则及其他选项特定设置的非重复的服务组成。 目录结构、注册表结构和服务名称都反映在 SQL Server 安装过程中创建的实例名称和特定实例 ID。

实例是默认实例或命名实例。 默认实例名为 MSSQLSERVER。 不需要客户端指定实例名称便可进行连接。 命名实例在安装过程中由用户决定。 您可以将 SQL Server 作为命名实例安装，无需先安装默认实例。 不论版本如何，一次均只能安装一个 SQL Server 默认实例。

注意 注意

使用 SQL Server SysPrep，您可以在"实例配置"页上完成已准备实例时指定实例名称。 如果在计算机上没有 SQL Server 的现有默认实例，您可以选择将正在完成的已准备实例配置为默认实例。

多实例

SQL Server 支持在单个服务器或处理器上存在多个 SQL Server 实例，但只能有一个实例为默认实例。 所有其他实例必须为命名实例。 一台计算机可同时运行多个 SQL Server 实例，每个实例独立于其他实例运行。

有关详细信息，请参阅 Maximum Capacity Specifications for SQL Server（SQL Server 最大容量规范）。

选项

仅限故障转移群集实例 - 指定 SQL Server 故障转移群集网络名称。 此名称可用来在网络上标识故障转移群集实例。

默认实例或命名实例 - 当您决定是安装 SQL Server 的默认实例还是命名实例时，请考虑以下信息：

  • 如果计划在数据库服务器上安装单个 SQL Server 实例，则该实例应为默认实例。

  • 如果您打算在同一台计算机上安装多个实例，请使用命名实例。 一台服务器只能承载一个默认实例。

  • 任何安装 SQL Server Express 的应用程序都应将其作为命名实例安装。 当同一台计算机中安装多个应用程序时，这样可以最大程度地减少冲突。

默认实例

选择该选项可安装 SQL Server 的默认实例。 一台计算机只能承载一个默认实例；所有其他实例必须是命名实例。 但是，如果您已经安装了 SQL Server 的默认实例，则可以向同一台计算机添加 Analysis Services 的默认实例。

命名实例

选择该选项可创建新的命名实例。 当对 SQL Server 实例进行命名时，请注意以下几点：

  • 实例名不区分大小写。

  • 实例名不能以下划线 (_) 开始或结束。

  • 实例名称不能包含词语"Default"或其他保留关键字。 如果在实例名中使用了保留关键字，将发生安装错误。 有关详细信息，请参阅 Reserved Keywords（保留关键字）。

  • 如果为实例名称指定 MSSQLServer，将创建默认实例。 对于 SQL Server Express，如果为实例名称指定 SQLExpress，将创建默认实例。

  • Microsoft SQL Server 2012 PowerPivot for SharePoint 安装始终安装为命名实例"PowerPivot"。 您不能为此功能角色指定不同的实例名称。

  • 实例名限制为 16 个字符。

  • 实例名中的第一个字符必须是字母。 可接受的字母为 Unicode 标准 2.0 定义的那些字母。 这些字母包括拉丁字符 a-z、A-Z 和其他语言中的字母字符。

  • 后续字符可以是 Unicode 标准 2.0 定义的字母、源于基本拉丁语或其他国家/地区书写符号的十进制数字、美元符号 ($) 或者下划线 (_)。

  • 实例名称中不允许含有空格或其他特殊字符， 也不允许存在反斜杠 (\)、逗号 (,)、冒号 (:)、分号 (;)、单引号 (')、and 符 (&) 和 at 符 (@)。

    注意 注意

    只有在当前 Windows 代码页中有效的字符才能用在 SQL Server 实例名称中。 如果使用了不支持的 Unicode 字符，将会发生安装错误。

检测到的实例和功能

查看正在运行 SQL Server 安装程序的计算机中安装的 SQL Server 实例和组件的列表。

实例 ID - 默认情况下，实例名称用作实例 ID。 这用于标识 SQL Server 实例的安装目录和注册表项。 默认实例和命名实例的默认方式都是如此。 对于默认实例，实例名称和实例 ID 为 MSSQLSERVER。 若要使用非默认的实例 ID，请在"实例 ID"字段中指定它。

重要说明 重要提示

使用 SQL Server SysPrep，在此页上显示的实例 ID 是在 SQL Server SysPrep 过程的准备映像步骤中指定的实例 ID。 在完成映像步骤中，您将无法指定不同的实例 ID。

注意 注意

不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

有关目录、文件位置和实例 ID 命名的详细信息，请参阅 SQL Server 的默认实例和命名实例的文件位置。

实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。 若要指定非默认的根目录，请单击"浏览"按钮或提供一个路径名。

SQL Server 的给定实例的所有组件作为一个单元进行管理。 所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

共用同一实例名称的所有 SQL Server 组件都必须满足以下条件：

  • 版本相同

  • 版本类别相同

  • 语言设置相同

  • 聚集状态相同

    注意 注意

    Reporting Services 不能识别群集。

  • 操作系统相同


实例选择（卸载）

[image]

实例选择（卸载）
发送反馈

在"实例选择 - 卸载"页上，使用下拉框指定要卸载的 SQL Server 实例。

选项

可以指定卸载 SQL Server 的整个实例，也可以指定仅卸载共享功能和管理工具。


实例选择(升级)

[image]

实例选择(升级)
发送反馈

使用"实例选择(升级)"页可以指定要升级的 SQL Server 实例。

选项

必须同时升级实例中的所有组件。 不能在升级过程中添加或删除功能。


要升级的实例

[image]

要升级的实例
请参阅 发送反馈

使用 SQL Server 安装向导的"要升级的实例"页可以指定要升级到 Microsoft SQL Server 2012 的 SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 实例。

选项

使用单选按钮指定是要升级 SQL Server 实例及其共享组件，还是只升级共享组件。 此 SQL Server 版本中的共享组件包括：

  • Integration Services

  • SQL Server 浏览器

  • SQL Server Active Directory Helper

  • SQL 编写器

有关支持的升级方案和已知升级问题的详细信息，请参阅 Version and Edition Upgrades（版本升级）。

请参阅

其他资源

使用升级顾问来准备升级
使用 SQL Server 的多个版本


卸载后

[image]

卸载后
发送反馈

使用"卸载后"页可以验证操作是否已成功完成。


准备映像进度

[image]

准备映像进度
请参阅 发送反馈

使用 SQL Server 安装向导的"准备映像进度"页可以监视 SQL Server 映像准备安装程序的状态。 在此步骤完成时，此页将列出在此过程中准备的每个 SQL Server 功能的状态。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


准备映像规则

[image]

准备映像规则
发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)


准备映像类型

[image]

准备映像类型
发送反馈

使用 SQL Server 安装向导的"准备映像类型"页可以指定是安装 Microsoft SQL Server 2012 的新实例还是向现有实例中添加功能。

选项

选择指示您所做选择的单选按钮：

  • 准备 Microsoft SQL Server 2012 的新实例

  • 向 Microsoft SQL Server 2012 的现有已准备实例中添加功能

    如果选择与向现有实例中添加功能相对应的选项，则使用下拉列表选择要更新的 SQL Server 已准备实例。

    注意 注意

    您可以向 SQL Server 的已准备映像添加 SQL Server SysPrep 支持的功能（数据库引擎和 Reporting Services）。 只有在已准备实例完成后，才能添加 SQL Server SysPrep 不支持的其他功能。


产品密钥

[image]

产品密钥
发送反馈

使用"产品密钥"页可以验证 SQL Server 的实例或者指定要安装哪个免费版本的 SQL Server。

选项

若要指定 SQL Server 的免费版本，请选择与免费安装相对应的单选按钮，然后使用下拉框来确定要安装的版本。

若要验证 SQL Server 的付费安装，请选择与"产品密钥"相对应的单选按钮，然后在提供的空间中提供密钥。

对于故障转移群集安装，请对所有故障转移群集节点使用相同的产品密钥。 如果产品密钥来自另一个版本的 SQL Server，将发生错误。


进度(卸载)

[image]

进度(卸载)
请参阅 发送反馈

使用"进度(卸载)"页可以监视安装进度。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


已准备好完成映像

[image]

已准备好完成映像
发送反馈

"已准备好完成映像"页提供应用于已准备实例配置的配置设置的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击"安装"。

  • 若要更改安装设置，请单击"上一步"。

  • 若要退出安装程序，请单击"取消"。


准备安装

[image]

准备安装
请参阅 发送反馈

"准备安装"页提供了 SQL Server 安装程序要安装或更改的功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击"安装"。

  • 若要更改安装设置，请单击"上一步"。

  • 若要退出安装程序，请单击"取消"。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


已可以准备映像

[image]

已可以准备映像
发送反馈

"已可以准备映像"页提供 SQL Server 安装程序准备的功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击"安装"。

  • 若要更改安装设置，请单击"上一步"。

  • 若要退出安装程序，请单击"取消"。


准备修复

[image]

准备修复
请参阅 发送反馈

"准备修复"页提供 SQL Server 安装程序执行的修复过程的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击"修复"。

  • 若要更改安装设置，请单击"上一步"。

  • 若要退出安装程序，请单击"取消"。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


删除 SQL Server 故障转移群集节点

[image]

删除 SQL Server 故障转移群集节点
发送反馈

使用"故障转移群集节点"页可识别要作为 Microsoft SQL Server 2012 故障转移群集节点删除的计算机。


修复进度

[image]

修复进度
请参阅 发送反馈

使用 SQL Server 安装向导的"修复进度"页可以监视 SQL Server 修复的状态。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


Reporting Services 配置选项 (SSRS)

[image]

Reporting Services 配置选项 (SSRS)
请参阅 发送反馈

使用 Microsoft SQL Server 安装向导中的"Reporting Services 配置"页来指定如何安装和配置报表服务器。 安装选项的可用性取决于您以前在"功能选择"页选择的选项以及在安装报表服务器的同时是否还安装了 SQL Server 数据库引擎的本地实例。

在某些情况下，如果安全套接字层 (SSL) 证书安装在计算机上并绑定到一个强通配符，安装程序将使用 HTTPS 前缀创建 Reporting Services URL。 有关如何将证书映射到 Reporting Services URL 的详细信息，请参阅 SQL Server 联机丛书中的为安全套接字层 (SSL) 连接配置报表服务器 (http://go.microsoft.com/fwlink/?LinkId=199089)。

有关 Reporting Services 和此发行版的安装和配置的最新信息，请参阅其他安装信息 (http://go.microsoft.com/fwlink/?LinkId=207425)。

选项

Reporting Services 本机模式

如果安装程序由于一条或多条要求未得到满足而无法执行默认的报表服务器配置，那么安装向导只允许选择最小化安装选项；同时，它会复制所需的文件，但要求在安装结束后，使用 Reporting Services 配置管理器来配置本机模式报表服务器。

注意 注意

如果选择默认安装选项之一，则现有的报表服务器数据库文件可能会导致安装失败。 当选择默认安装选项时，安装程序将尝试使用默认名称创建报表服务器数据库。 如果使用该名称的数据库已经存在，安装程序将失败，您必须回滚安装。 若要避免此问题，可在运行安装程序前重命名现有数据库，或选择"仅安装"选项，以便在安装完成后指定自定义数据库设置。

安装和配置

在本机模式下使用报表服务器数据库、服务帐户和 URL 保留项的默认值安装报表服务器实例。 如果选择此选项，那么当安装程序完成后，报表服务器实例即可使用。 安装程序通过使用本地数据库引擎实例来创建报表服务器数据库，并配置报表服务器，使其使用默认值。

仅当报表服务器安装中使用的默认值对您的系统有效时，此选项才可用。 建议希望在本地安装所有组件的开发人员和评估软件的用户使用此选项。

若要查看关于安装程序所用默认设置的信息，或者要找出默认配置无法安装的原因，请单击"详细信息"。 有关本机模式报表服务器的默认配置的详细信息，请参阅本机模式安装的默认配置 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091)。

仅安装

安装报表服务器程序文件，创建报表服务器服务帐户，并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。 此安装选项称为"仅文件"安装。 如果不希望使用默认配置，则选择此选项。 如果不能安装默认配置或如果安装包括 Reporting Services 的 SQL Server 故障转移群集，这是唯一可用的选项。有关仅文件安装的详细信息，请参阅仅文件安装 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093)。

安装程序完成后，必须先创建报表服务器数据库并配置报表服务器，服务器才可以使用。 若要配置报表服务器并创建数据库，请使用 Reporting Services 配置管理器。 有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置） (http://go.microsoft.com/fwlink/?LinkId=199094) 和配置报表服务器数据库连接 (http://go.microsoft.com/fwlink/?LinkId=199095)。

Reporting Services SharePoint 模式

仅安装

安装报表服务器程序文件和 PowerShell cmdlet。 安装完成后您将需要启动 Reporting Services SharePoint 服务并创建一个 Reporting Services 服务应用程序。 有关详细信息，请参阅为 SharePoint 集成安装和配置 Reporting Services 服务概述 (http://go.microsoft.com/fwlink/?LinkId=207543)、创建 SQL Server Reporting Services 服务应用程序 (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544) 和 Reporting Services 和 SharePoint 集成概述 (http://go.microsoft.com/fwlink/?LinkID=207244)。

安装用于 SharePoint 技术的 Reporting Services 外接程序

从 Microsoft SQL Server 2012 版本开始，可以在 SQL Server 安装向导的功能选择页中将此外接程序作为 SQL Server 安装的一部分进行安装.

但是，您可以使用以下方法之一安装适用于 SharePoint 2010 的 Reporting Services 外接程序：

  • 运行 SharePoint 2010 产品准备工具 PreRequisiteInstaller.exe。

  • 从 SQL Server 安装介质安装。 在 SQL Server 安装程序完成后，在 SQL Server 安装介质上的 Setup 文件夹中单击 rsSharePoint.msi 文件。

  • 下载并安装此外接程序。 有关详细信息，请参阅在何处查找用于 SharePoint 产品的 Reporting Services 外接程序 (http://go.microsoft.com/fwlink/?LinkID=208634)。

请参阅

其他资源

如何启动 Reporting Services 配置管理器
如何创建报表服务器数据库（Reporting Services 配置）
安装 Reporting Services 的注意事项
本机模式安装默认配置 (Reporting Services)
SharePoint 集成模式默认配置 (Reporting Services)
从命令提示符安装 SQL Server


Reporting Services SharePoint 模式升级 (SSRS)

[image]

Reporting Services SharePoint 模式升级 (SSRS)
请参阅 发送反馈

使用 Reporting Services SharePoint 模式页可以确认是否升级了所有共享功能。 Reporting Services SharePoint 模式是一个 SQL Server 共享功能，将随所有其他 SQL Server 共享功能一起升级。 SQL Server 安装向导不支持只升级一个共享功能。 所有 SQL Server 共享功能将同时升级。

选项

只有选中了"继续升级"复选框，"下一步"按钮才可用。 如果您未选中此复选框，则无法继续升级。

有关详细信息，请参阅 Reporting Services 升级 (http://go.microsoft.com/fwlink/?LinkId=199092)。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件

其他资源

从命令提示符安装 SQL Server


Reporting Services SharePoint 模式身份验证

[image]

Reporting Services SharePoint 模式身份验证
请参阅 发送反馈

使用 Microsoft SQL Server 安装向导的"Reporting Services SharePoint 模式身份验证"页可以指定在当前 Reporting Services 安装中使用的服务帐户的凭据。 这些凭据将用来创建新的 SharePoint 应用程序池。 此外，还将创建一个新的 Reporting Services SharePoint 服务应用程序。 客户端应用程序名称将包含前一个 Reporting Services 实例的名称。

选项

  • "SSRS 应用程序池帐户名称:"选项是只读的。 系统将自动使用来自您正在升级的现有 Reporting Services 安装中的当前值填充此值。

  • 如果应用程序池帐户不需要密码，则将禁用"SSRS 应用程序池帐户密码:"选项。 例如，"NT Authority\NetworkSerivce"。 如果应用程序池帐户的确需要密码，仅当您键入正确的密码，才能继续进行升级。

有关详细信息，请参阅 Reporting Services 升级 (http://go.microsoft.com/fwlink/?LinkId=199092)。

请参阅

其他资源

Reporting Services 升级


选择已准备实例

[image]

选择已准备实例
发送反馈

使用"选择已准备实例"页可以指定要完成的已准备实例。

选项

"选择实例 ID"框列出您可以完成的已准备实例。 选择要完成的已准备实例。

选择实例 ID

该列表包括在正在运行 SQL Server 安装程序的计算机上您可以完成的所有已准备实例。 选择要完成的已准备实例。

已安装的实例

这包括已安装、已准备和已完成实例。


服务器配置 - 排序规则

[image]

服务器配置 - 排序规则
发送反馈

可以在 SQL Server 安装向导的"服务器配置 - 排序规则"页上修改数据库引擎和 Analysis Services 排序时所用的排序规则设置。 选择相应选项以匹配其他 SQL Server 安装或者其他计算机的排序规则设置。

选项

为 SQL Server 和 Analysis Services 进行自定义

SQL Server 提供了两组排序规则：Windows 排序规则和 SQL Server 排序规则。 您可以为数据库引擎和 Analysis Services 指定不同的排序规则设置，也可以为它们指定相同的排序规则。

默认情况下，对于美国英语系统区域设置，选择的是 SQL Server 排序规则。 SQL Server 本地化版本的默认排序规则由您计算机的 Windows 系统区域设置决定。 有关详细信息，请参阅Using SQL Collations。

仅当此 SQL Server 安装的排序规则设置必须与另一 SQL Server 实例所用的排序规则设置相匹配，或者必须与另一台计算机的 Windows 系统区域设置相匹配时，才应更改默认设置。

注意 Analysis Services 仅使用 Windows 排序规则。 如果计划安装 Analysis Services，请在 SQL Server 安装期间，选择 Windows 排序规则，以确保 SQL Server 数据库引擎和 Analysis Services 之间结果的一致性。

有关详细信息，请参阅 Collation Settings in Setup（安装程序中的排序规则设置）。

最佳做法

有关 SQL Server 安装程序使用的 Windows 系统区域设置以及相应的默认排序规则的表的详细信息，请参阅 Collation Settings in Setup（安装程序中的排序规则设置）。

如果可能，请为您的组织使用一个排序规则。 这样就不必为每个数据库、列、表达式或标识符显式指定排序规则。 如果必须使用多个排序规则和代码页设置，请对查询进行编码，以考虑排序规则优先顺序规则。 有关详细信息，请参阅联机丛书主题 Collation Precedence (Transact-SQL)（排序规则优先顺序 (Transact-SQL)）。

为 SQL Server 选择排序规则时，请考虑下列建议：

  • 如果基于二进制码位的排序顺序可接受，请选择 BINARY2 排序规则。

  • 选择 Windows 排序规则以便在各数据类型之间进行一致的比较。

  • 使用新的 100 级排序规则以便获得更好的语言排序支持。 有关详细信息，请参阅 Collation and Unicode Support（排序规则和 Unicode 支持）。

  • 如果您计划将数据库迁移到 SQL Server 的升级实例，则选择与您的数据库的现有排序规则匹配的排序规则。


服务器配置 - 服务帐户

[image]

服务器配置 - 服务帐户
请参阅 发送反馈

使用 SQL Server 安装向导的"服务器配置"页可以为 SQL Server 服务分配登录帐户。 此页上配置的实际服务取决于您选择安装的功能。

用于启动和运行 SQL Server 的启动帐户可以是域用户帐户、本地用户帐户、托管服务帐户、虚拟帐户或内置系统帐户。

选项

您可以为所有的 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。 您还可以指定是自动启动、手动启动还是禁用服务。 对于大多数安装建议采用默认帐户。

  • 在 Windows 7 和 Windows Server 2008 R2 上，大多数帐户默认为虚拟帐户。

  • 在 Windows Vista 和 Windows Server 2008 上，大多数帐户默认为 NETWORK SERVICE 帐户。

  • 在 Windows Server 2008 上的群集安装中，您必须提供一个域帐户。

如果将服务配置为使用域帐户，Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。 有关包含帐户类型的说明的详细信息，请参阅 Setting Up Windows Service Accounts（设置 Windows 服务帐户）。

单独配置 SQL Server 服务帐户(建议)

使用网格为每项 SQL Server 服务设置一个登录用户名和密码并设置相应服务的启动类型。 您可以对 SQL Server 服务使用内置系统帐户、本地帐户、本地组、域组或域用户帐户。

选择下列任一服务以自定义其设置。

选择此服务

为其配置身份验证设置的主体

SQL Server 代理

执行作业、监视 SQL Server 并允许管理任务自动完成的服务。

此服务没有默认登录帐户。

默认的启动类型为"手动"。

SQL Server

SQL Server 数据库引擎。

默认的启动类型为"自动"。

注意 注意

SQL Server Browser

SQL Server Browser 是向客户端计算机提供 SQL Server 连接信息的名称解析服务。 多个 SQL Server 和 Integration Services 实例共享此服务。

默认的登录帐户为 NT Authority\Local service 且在 SQL Server 安装期间无法更改。 可以在安装完成后更改该帐户。

如果未在安装期间指定启动类型，可以根据以下内容来确定：

  • SQL Server Browser 设置为"自动"并在下面描述的安装方案中运行：

    • SQL Server 故障转移群集实例

    • 启用了 TCP 或 NP 的 SQL Server 命名实例

    • 分析服务器的命名实例，未进行群集

  • 如果上述方案均不符合并且已经安装 SQL Server Browser，将保持 SQL Server Browser 的当前状态。

  • 如果在安装前没有现有的 SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 实例，则启动类型会设置为"已禁用"且被停止。

Analysis Services

Analysis Services.

默认的启动类型为"自动"。

对于 SharePoint 集成模式，您必须指定一个 Windows 域用户帐户。 您指定的帐户用于 Analysis Services 服务。 您为当前实例指定的帐户还必须用于您以后添加到同一场的任何附加 Analysis Services 实例。

Reporting Services

Reporting Services. 服务帐户用于配置报表服务器数据库连接。 如果要使用默认的身份验证设置，请选择内置的网络服务。 如果指定域用户帐户，并且要在报表服务器上使用 Windows 身份验证，请确保为该帐户注册一个服务主体名称 (SPN)。 有关详细信息，请参阅 How to: Configure Windows Authentication in Reporting Services（如何在 Reporting Services 中配置 Windows 身份验证）。

重要说明 重要提示

Microsoft 建议，如果有具有较低特权的帐户可供使用，则不要对 SQL Server 或 SQL Server Agent 服务使用 Network Service 帐户，因为 Network Service 是可共享帐户。 只有能够确保计算机上未安装使用 Network Service 帐户的其他服务时，该 Network Service 帐户才适合用作 SQL Server 服务帐户。 非 Windows 管理员的 Local User 帐户或 Domain User 帐户更适用于 SQL Server 服务。

默认的启动类型为"自动"。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

默认的启动类型为"自动"。

SQL Server 全文筛选器后台程序启动器

创建 fdhost.exe 进程的服务。 需要使用此服务来承载为全文索引处理文本数据的断字符和筛选器。

如果提供运行 FDHOST 启动器服务的域帐户，我们强烈建议您使用低特权的帐户。 此帐户应该不同于用于 SQL Server 服务的帐户。 在 Windows Vista 和 Windows Server 2008 上，FDHOST 启动器服务帐户默认为 LOCAL SERVICE。

SQL Server 分布式重播客户端

用于分布式重播客户端服务的服务帐户。

提供运行分布式重播客户端服务的帐户。 此帐户应该不同于用于 SQL Server 服务的帐户。

默认的启动类型为"手动"。

SQL Server 分布式重播控制器

用于分布式重播控制器服务的服务帐户。

提供运行分布式重播控制器服务的帐户。 此帐户应该不同于用于 SQL Server 服务的帐户。

默认的启动类型为"手动"。

请参阅

其他资源

安装 SQL Server 的安全注意事项


安装角色

[image]

安装角色
请参阅 发送反馈

使用此页可以指定是使用"功能选择"页来分别选择各项功能，还是使用安装角色来进行安装。

通过setup role，可以固定选择实现预定义的 SQL Server 配置所需的所有功能和共享组件。

选项

SQL Server 功能安装

选择此选项可分别选择各项功能和共享组件。 实例功能包括数据库引擎服务、Analysis Services（本机模式）和 Reporting Services。

SQL Server PowerPivot for SharePoint

选择此选项可以在 SharePoint 2010 场中安装 Analysis Services 服务器组件。 此选项在场中部署 PowerPivot 系统服务和 Analysis Services 服务器，同时支持对包含嵌入式 PowerPivot 数据的已发布 Excel 工作簿进行查询和数据处理。

如果需要使用关系数据库引擎实例在 SharePoint 场中承载数据库，可以选择在安装中添加关系数据库引擎实例。 如果已配置场，则不必选择。

安装完成后，必须使用以下方法之一配置软件：PowerPivot 配置工具、PowerShell cmdlet 或 SharePoint 2010 管理中心。 与以往的版本相比，安装程序不再执行 PowerPivot 安装的任何配置任务。

基于角色的安装不包含 SQL Server PowerPivot for Excel 客户端应用程序。 将单独安装此客户端应用程序。

所有功能以及默认值

选择此安装角色将安装此版本提供的所有功能。 请注意，从该角色中排除 PowerPivot for SharePoint。 您必须使用 PowerPivot for SharePoint 安装角色来安装该功能。

数据库引擎配置为使用 NT AUTHORITY\NETWORK SERVICE 帐户开始。 当前用户将设置为 SQL Server sysadmin 角色的成员。 此选项设置的值可以通过指定其他命令行参数来覆盖。

在 Windows Vista 或 Windows Server 2008 或更高版本中，当操作系统不是域控制器时，默认情况下，数据库引擎和 Reporting Services 将使用 NTAUTHORITY\NETWORK SERVICE 帐户，Integration Services 将使用 NTAUTHORITY\NETWORK SERVICE 帐户，而 SQL 全文筛选器后台程序启动器将使用 NTAUTHORITY\LOCAL SERVICE 帐户。

请参阅

参考

功能选择

其他资源

安装 PowerPivot for SharePoint
硬件和软件要求 (PowerPivot for SharePoint)


SQL Server 故障转移群集向导 - 完成

[image]

SQL Server 故障转移群集向导 - 完成
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


SQL Server 故障转移群集向导 - 安装

[image]

SQL Server 故障转移群集向导 - 安装
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


SQL Server 故障转移群集向导 - 准备

[image]

SQL Server 故障转移群集向导 - 准备
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


摘要（升级）

[image]

摘要（升级）
发送反馈

使用"摘要"页可以查看为该升级指定的选项。


安装程序支持规则

[image]

安装程序支持规则
发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

其他规则主题

有关方案特定的安装规则，请参阅以下主题：

  • 安装规则

  • 升级规则检查

  • 版本升级规则

  • 卸载规则

  • 准备映像规则

  • 完成映像规则


卸载规则

[image]

卸载规则
请参阅 发送反馈

"卸载规则"页将运行一组规则来确保可以成功完成安装操作。

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动 SQL Server 卸载向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


升级进度

[image]

升级进度
请参阅 发送反馈

使用 SQL Server 安装向导的"升级进度"页可以监视 SQL Server 升级的状态。

请参阅

概念

查看和读取 SQL Server 安装程序日志文件


升级规则检查

[image]

升级规则检查
请参阅 发送反馈

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。 在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。 SCC 将检查阻止 SQL Server 安装操作成功完成的条件。 在安装程序启动升级向导之前，SCC 会检索每个项的状态。 然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

系统配置检查将会生成一个报告，该报告包含有关每个执行规则的简短说明以及执行状态。 该系统配置检查报告位于 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

在执行安装操作之前，请查看以下主题：

  1. 用于安装 SQL Server 的硬件和软件要求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各个版本支持的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. 安装 SQL Server 的安全注意事项(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的本地语言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他参考：

  1. 支持的版本升级(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安装故障转移群集前的准备工作(http://go.microsoft.com/fwlink/?LinkId=235034)

请参阅

参考

安装程序支持规则


确认卸载选项

[image]

确认卸载选项
发送反馈

确认您的选择，然后单击"下一步"继续。


您正查看的主题不可用

[image]

您正查看的主题不可用
发送反馈

安装完成之后，您可以通过以下方式查看 SQL Server 的文档：单击"帮助"；在对话框或界面元素中按 F1 键；或者从"开始"菜单中依次指向"所有程序"、Microsoft SQL Server、"帮助和社区，然后单击"SQL Server 联机丛书"。 有关详细信息，请参阅添加和删除帮助集。